Opened 9 years ago

Closed 9 years ago

#5949 closed Bug (worksforme)

IE8 Cursor jumps out of Table cell when we click on a Table Cell

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3
Keywords: IBM IE Cc: Damian, joek

Description

To reproduce the defect

  1. Open Ajax sample & Create a Table with 30 Rows & 30 Columns.
  1. Position the cursor in one of the Table Cells in the last row.
  1. Drag the slide bar to the top of the page.
  1. Now Click in one of the Table Cells in the First row.

Expected Result:

Cursor stays in the Cell that we have clicked and the user can enter the content.

Actual Result:

Cursor jumps out of the cell to a cell in a different row.

Change History (7)

comment:1 Changed 9 years ago by Sa'ar Zac Elias

Keywords: WorksForMe added
Milestone: CKEditor 3.4

I'm not able to reproduce the bug using the current trunk. Could you confirm that?

comment:2 in reply to:  1 Changed 9 years ago by Satya Minnekanti

Replying to Saare:

I'm not able to reproduce the bug using the current trunk. Could you confirm that?

I have tried on nightly build and i could reproduce it.Rember my IE8 is in non-compatiability view

comment:3 Changed 9 years ago by Sa'ar Zac Elias

Keywords: IE added

I'm still unable to reproduce the bug with IE8 with all available modes. Are you able to reproduce the bug with the samples?

comment:4 Changed 9 years ago by Joe Kavanagh

Milestone: CKEditor 3.4

I am able to reproduce this behaviour on the nightly build, revision [5668]. I typed a incremental number in the first cell of each row; 1 - 30. I place the cursor in a cell on row 30, then scroll up and place the cursor in a cell on row 1. The cursor jumps down to row 21. I then scroll down and place the cursor in a cell on row 30. The cursor jumps up to row 28. The cursor jumps to the same rows each time.

comment:5 Changed 9 years ago by Sa'ar Zac Elias

I always get the expected result. Can anybody else confirm the bug?

comment:6 Changed 9 years ago by Tobiasz Cudnik

I can't reproduce this using following steps, although once i was affected by cursor jumping to wrong cell. It seems like a random case for me.

comment:7 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4
Resolution: worksforme
Status: pendingclosed

I'm not able to reproduce it on the current trunk also. It may have been fixed in another ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy