Opened 7 years ago

Closed 7 years ago

#6000 closed Bug (fixed)

Safari scrolls to top on initial click and headline formatting

Reported by: André Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.4
Component: General Version: 3.3
Keywords: WebKit Cc:

Description

You can reproduce it while going to the demo, scroll down to the end and click on the last paragraph. The focus will be set right but the editor window will scroll up. Same happens when going down to the last paragraph and make a headline out of a normal text.

This is totally annoying for long texts and in the case of headline it make the editing a pain, as you have to find you headline each time you create one :-(

Mac OS X 10.6.4 Safari 5.0

Attachments (2)

6000.patch (840 bytes) - added by Sa'ar Zac Elias 7 years ago.
6000_2.patch (829 bytes) - added by Frederico Caldeira Knabben 7 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by Sa'ar Zac Elias

Keywords: Scroll removed
Status: newconfirmed

Looks like a browser bug.. need some investigation.

comment:2 Changed 7 years ago by André

This was introduced in 3.3, in 3.2.2 it worked correctly. So rather a CKEditor bug. It seems that the position of the cursor does get lost.

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4

comment:4 Changed 7 years ago by kmonty

#5981 is related (the bug exists in Chrome as well)

comment:5 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: WebKit added; Safari removed

comment:6 Changed 7 years ago by Sa'ar Zac Elias

Version: 3.3.13.3

Regression of [5391].

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 6000.patch added

comment:7 Changed 7 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedreview

comment:8 Changed 7 years ago by Frederico Caldeira Knabben

Owner: changed from Sa'ar Zac Elias to Frederico Caldeira Knabben
Status: reviewassigned

I've found the source of the issue. In fact, we're focusing the documentElement, which is not anymore the editable container, which is not <body>.

I'll come with a new patch for it.

Changed 7 years ago by Frederico Caldeira Knabben

Attachment: 6000_2.patch added

comment:9 Changed 7 years ago by Frederico Caldeira Knabben

Status: assignedreview

The problem is created by code introduced with [5509] for #5713. That one was good for designMode, but now things changed with contenteditable.

It's enough to remove part of that code, which looks like not needed anymore. I've tested the patch with Chrome and Safari Windows and Mac, and it works well. I see no problems with selection being lost, not even with the focus and blur events.

comment:10 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:11 Changed 7 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with [5785].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy