Ticket #6039 (closed Bug: invalid)

Opened 4 years ago

Last modified 13 months ago

FF3: Home page (base href) appearing in text area iframe

Reported by: papanel Owned by:
Priority: Normal Milestone:
Component: General Version: 3.2.2
Keywords: Cc: nsheth@…

Description

In some cases, the base href of the domain appears in the textarea iframe. This has been reported in Firefox, versions 3.6.6+.

Unable to reproduce consistently.

Screenshot here: http://content-img.experienceproject.com/1277817629Tj0fsl.jpg

Originally noticed in ckeditor 3.2.2, but problem persists in 3.3.1.

Change History

comment:1 Changed 4 years ago by papanel

  • Cc nsheth@… added

Additional info -

In terms of when this happens - From reports, the editor loads, then the text area inside the editor flashes white, and then our home page loads into the text area. (When things are correct, the editor has a background color, non-white.) Users can usually reload the page to make things work normally.

We usually don't preload anything into the editor.

Our editor include code looks something like:

<textarea cols="300" id="message" name="message" rows="100"></textarea>
<script type='text/javascript' src='ckeditor/ckeditor.js'></script>
<script type="text/javascript">
    CKEDITOR.config.toolbar = 'Basic';
    CKEDITOR.replace( 'message',
    {
        height:'100px',
        width:'300px'
    });
</script>

comment:2 Changed 4 years ago by fredck

  • Status changed from new to pending

What do you have in your editor configuration file?

Also, it looks like we would hardly be able to reproduce the problem here. Can you provide us a test page that we can use for that?

comment:3 Changed 4 years ago by papanel

Here's my config.js file:

/*
Copyright (c) 2003-2010, CKSource - Frederico Knabben. All rights reserved.
For licensing, see LICENSE.html or http://ckeditor.com/license
*/
CKEDITOR.config.toolbar_Blog = [
['Bold','Italic','Underline','Strike','TextColor','BGColor','Font','FontSize','-',
'Image','MediaEmbed','Link','Unlink','-','NumberedList','BulletedList',
'-','Smiley','-','SpellCheck','Scayt','Preview','-','Source']
] ;
CKEDITOR.config.toolbar_Story =
[
['Bold','Italic','Underline','Strike','-','Image','MediaEmbed',
'-','NumberedList','BulletedList','-','Smiley',
'-','SpellCheck','Scayt','Preview','ajaxAutoSave']
];
CKEDITOR.config.toolbar_Story_NOAS =
[
['Bold','Italic','Underline','Strike','-','Image','MediaEmbed',
'-','NumberedList','BulletedList','-','Smiley','-',
'SpellCheck','Scayt','Preview']
];
CKEDITOR.config.toolbar_Minimal = [
['Scayt','Preview']
] ;

CKEDITOR.config.toolbar_Basic = [
['Bold','Italic','Underline','StrikeThrough','-',
'OrderedList','UnorderedList','-','Smiley','-',
'SpellCheck','Scayt','Preview']
] ;
CKEDITOR.config.toolbar_Basic_No_Smiley = [
['Bold','Italic','Underline','StrikeThrough','-',
'OrderedList','UnorderedList','-','SpellCheck','Scayt','Preview']
] ;

CKEDITOR.config.toolbar_Message = [
['Bold','Italic','Underline','StrikeThrough','-','Image','Link','Unlink',
'-','Smiley','-','SpellCheck','Scayt','Preview']
] ;

CKEDITOR.config.toolbar_PM = [
['Bold','Italic','Underline','-','Smiley',
'-','SpellCheck','Scayt','Preview']
] ;

CKEDITOR.config.toolbar_Partner = [
['Bold','Italic','Underline','StrikeThrough','-','Link','Unlink',
'-','OrderedList','UnorderedList','-','SpellCheck','Scayt','Preview']
] ;

CKEDITOR.config.resize_enabled = false;
CKEDITOR.config.removePlugins = 'elementspath'; 
CKEDITOR.config.extraPlugins = 'MediaEmbed,ajaxAutoSave,aspell';

CKEDITOR.config.enterMode = CKEDITOR.ENTER_BR;
CKEDITOR.config.scayt_autoStartup = false;

CKEDITOR.on( 'dialogDefinition', function( ev )
{
	// Take the dialog name and its definition from the event
	// data.
	var dialogName = ev.data.name;
	var dialogDefinition = ev.data.definition;

	// Check if the definition is from the dialog we're
        // interested on (the 'Image' dialog).
	if ( dialogName == 'image' )
	{
	    // Remove the 'Link' and 'Advanced' tabs from the 'Image' dialog.
	    //dialogDefinition.removeContents( 'advanced');
	    dialogDefinition.removeContents( 'Link');
	    /*
	    var infoTab = dialogDefinition.getContents( 'info' );

	    // Remove unnecessary widgets from the 'Image Info' tab.         
	    infoTab.remove( 'txtHeight');         
	    infoTab.remove( 'txtWidth' );         
	    infoTab.remove( 'btnLockSizes');      // not working!!!
	    infoTab.remove( 'btnResetSize');      // not working!!!
	    infoTab.remove( 'txtBorder');
	    infoTab.remove( 'txtHSpace');
	    infoTab.remove( 'txtVSpace');
	    infoTab.remove( 'cmbAlign' );
	    infoTab.remove( 'previewImage');
	    infoTab.remove( 'ImagePreviewLoader');   // not working!!!
	    infoTab.remove( 'ImagePreviewBox');      // not working!!!
	    */
	}
});
CKEDITOR.editorConfig = function( config )
{
	// Define changes to default configuration here. For example:
	// config.language = 'fr';
	// config.uiColor = '#AADC6E';
};

Unfortunately, I haven't figured out how to reproduce the error, just relying on user reports.

Note, we've had the problem go away by delaying the loading of ckeditor, perhaps that gives some insight into what the issue is:

<script type="text/javascript">
  setTimeout("CKEDITOR.config.toolbar = '<?=$tool_bar?>',
CKEDITOR.replace('<?=$textarea_id?>',
{<?=$extra_editor_params?>});",1000);
</script>

comment:4 Changed 13 months ago by Reinmar

  • Status changed from pending to closed
  • Resolution set to invalid

This is not enough to reproduce this issue. I'm closing it, but of course if we'll see that it's still reproducible, we can reopen it.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy