Opened 10 years ago

Closed 10 years ago

#6056 closed Bug (fixed)

Floating panels don't have scrollbars

Reported by: Sa'ar Zac Elias Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.4
Component: UI : Floating Panel Version: SVN (CKEditor) - OLD
Keywords: IE8 Cc:

Description

IE + Quirks: floating panels don't have scrollbars.

Attachments (2)

Screenshot_6056.png (4.2 KB) - added by Sa'ar Zac Elias 10 years ago.
6056.patch (4.4 KB) - added by Sa'ar Zac Elias 10 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by Charlie

Picture? I'm confused, should they? I can work on it if you want.

Changed 10 years ago by Sa'ar Zac Elias

Attachment: Screenshot_6056.png added

comment:2 Changed 10 years ago by Sa'ar Zac Elias

Keywords: IE8 added; IE removed

Works well with IE7.

comment:3 Changed 10 years ago by Sa'ar Zac Elias

Regression of [5668].

comment:4 Changed 10 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: newreview

The patch reverts [5668] and fixed the related bug in a diefferent approach.

Changed 10 years ago by Sa'ar Zac Elias

Attachment: 6056.patch added

comment:5 in reply to:  3 Changed 10 years ago by Frederico Caldeira Knabben

Replying to Saare:

Regression of [5668].

That's weird, considering that [5668] changes the v2 and office2003 skins only, and your screenshot looks like kama.

I'm not able to reproduce this problem in any way :/

comment:6 Changed 10 years ago by Sa'ar Zac Elias

It happens for all skins, not just the kama. It is a regression of [5668] and another unknown changeset. It's only reproducible on IE8+Quirks.

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

Status: reviewassigned

This is the other changeset [4943].

I'm still not able to reproduce it here, but it looks like this one depends on the machine used for testing (IE weirdness).

So, if you confirm that the patch doesn't bring regression to the [4943] and [5668] fixes, I'm ok with it.

comment:8 Changed 10 years ago by Sa'ar Zac Elias

Status: assignedreview

I can't see a regression.

comment:9 Changed 10 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:10 Changed 10 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [5783].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy