Ticket #6100 (closed Bug: fixed)

Opened 4 years ago

Last modified 3 years ago

BIDI: when we change Table language direction indentation of text in Table cells is not applied correctly.

Reported by: satya Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.4.2
Component: General Version: 3.3
Keywords: IBM Cc: damo,joek

Description

To reproduce the defect:

  1. Open Ajax sample.
  1. Insert a Table and enter text in all Table cells, Indent the text in few cells.
  1. Activate Context menu and select Table properties option.
  1. In the Table Properties dialog on Advanced Tab, change the Language direction of the Table to Right to Left(RTL) and click OK button.

Expected Result:

Table language direction is changed to right,Table cells should be shown as reversed,Table Cells & text in Table cells should appear as a mirror image of Table in previous step and indentation for Paragraphs in Table cells should be changed from left to right.

Actual Result:

Table language direction is changed to right,Table cells are shown as reversed,Table Cells & text in Table cells are appearing as a mirror image of Table in previous step but the indentation for Paragraphs in Table cells still shown as left.

Attachments

Screenshot_6100.png (28.4 KB) - added by fredck 4 years ago.
Screenshot with the current results.
6100.patch (3.2 KB) - added by tobiasz.cudnik 4 years ago.
6100_2.patch (3.2 KB) - added by tobiasz.cudnik 3 years ago.

Change History

Changed 4 years ago by fredck

Screenshot with the current results.

comment:1 follow-up: ↓ 2 Changed 4 years ago by fredck

  • Status changed from new to pending

It WFM here. Maybe I simply didn't understand the issue. So, just to be sure, I've attached screenshots of the editor, before and after changing the table direction.

Should we have anything different here?

comment:2 in reply to: ↑ 1 Changed 4 years ago by satya

Replying to fredck:

It WFM here. Maybe I simply didn't understand the issue. So, just to be sure, I've attached screenshots of the editor, before and after changing the table direction.

Should we have anything different here?

we are talking about indentation of the text in Table cells and it's not changing when you change language direction.you have not applied any indentation to the text in your Table cells.

look at step 2 i have asked to apply some indentation to the text in few cells.

comment:3 Changed 4 years ago by fredck

  • Status changed from pending to confirmed

Ok, my fault. Step 2 has two steps on it, and the second got unobserved.

The problem is that the dialog doesn't perform the same margin switching procedure that is instead executed by the BiDi buttons.

It looks like we'll have to implement a generic solution for it, controlled by the indentation plugin, so we make this feature more generic.

comment:4 Changed 4 years ago by tobiasz.cudnik

I think we just miss lang switch event, to which other plugins could subscribe their content changes.

comment:5 Changed 4 years ago by fredck

Something similar to the event we've introduced for the Remove Format feature would do. So, whenever some code changes the direction of an element, the "dirChanged" event is fired.

comment:6 Changed 4 years ago by tobiasz.cudnik

  • Status changed from confirmed to assigned
  • Owner set to tobiasz.cudnik

Changed 4 years ago by tobiasz.cudnik

comment:7 Changed 4 years ago by tobiasz.cudnik

  • Status changed from assigned to review

comment:8 follow-up: ↓ 9 Changed 4 years ago by damo

Can we assign this to 3.4.2?

comment:9 in reply to: ↑ 8 Changed 3 years ago by garry.yao

Replying to damo:

Can we assign this to 3.4.2?

Ok as it's quite a small change, right now we'll not be adding any more to 3.4.2.

comment:10 Changed 3 years ago by garry.yao

  • Status changed from review to review_passed
  • Milestone set to CKEditor 3.4.2

comment:11 Changed 3 years ago by tobiasz.cudnik

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [5954].

comment:12 Changed 3 years ago by garry.yao

  • Status changed from closed to reopened
  • Resolution fixed deleted

Changeset is broken new table creation, revert with [5959], patch must be revised.

comment:13 Changed 3 years ago by garry.yao

  • Status changed from reopened to confirmed

Changed 3 years ago by tobiasz.cudnik

comment:14 Changed 3 years ago by tobiasz.cudnik

  • Status changed from confirmed to review

The reason was lack of a parent during the table creation. Ive added a dedicated check for this situation.

comment:15 Changed 3 years ago by garry.yao

  • Status changed from review to review_passed

comment:16 Changed 3 years ago by tobiasz.cudnik

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [5968].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy