Ticket #611 (closed New Feature: duplicate)

Opened 7 years ago

Last modified 13 months ago

View source code of selection

Reported by: anonymous Owned by:
Priority: Normal Milestone:
Component: UI : Source View Version: 4.0
Keywords: SF Cc:

Description

It would be nice if we had selected part of the text inside the editor to be able with a "view HTML source" feature to see the HTML code of this selection only not the whole text.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1096342&group_id=75348&atid=543656

Change History

comment:1 Changed 7 years ago by martinkou

  • Reporter changed from martinkou to anonymous

I think it would be enough to just select/hilight the selection in Source mode, so for example if I select an image in design mode and then switch to source mode that the image tag get's highlighted and scrolled into view if nessesary. This functionality existed as a patch/hack for fckeditor1.6. Also it should do the same thing in reverse when something is selected in source mode and then you switch back to design mode that the selection is kept. This solution would be easier and less confusing as there is no sepperate button to just show the (read only) selection source.


Moved from SF. Original poster: Anonymous

comment:2 Changed 7 years ago by alfonsoml

  • Component changed from General to UI : Source View

comment:3 Changed 6 years ago by w.olchawa

  • Keywords Confirmed added

comment:4 Changed 13 months ago by sirtet

  • Version set to 4.0

this seems to be a duplicate of 3709

which provides a patch (for 4.0) for keeping the selection.

comment:5 Changed 13 months ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to duplicate

Looking at comment from @martinkou I think this can be qualified as duplicate. Thanks @sirtet.

DUP of #3709.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy