Opened 7 years ago

Closed 7 years ago

#6129 closed Bug (fixed)

BIDI: Show Blocks should show the HTML Tags on the Right for RTL Languages

Reported by: Satya Minnekanti Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.4.1
Component: General Version: 3.0
Keywords: IBM Cc: Damian, joek

Description

To reproduce the defect:

  1. Open Language sample and change the language to Hebrew or Arabic.
  1. Type some text and click on Show Blocks icon.

Expected Result:

Blocks in the Editor body is shown and HTML Tags for the Paragraphs are displayed on the right hand side since we are using a Right to Left(RTL) Language sample.

Actual Result:

Blocks in the Editor body is shown and HTML Tags for the Paragraphs are displayed on the left hand side.

Attachments (3)

6129.patch (1.1 KB) - added by Sa'ar Zac Elias 7 years ago.
images.zip (3.7 KB) - added by Sa'ar Zac Elias 7 years ago.
images_2.zip (2.6 KB) - added by Frederico Caldeira Knabben 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by Sa'ar Zac Elias

Milestone: CKEditor 3.4.1
Owner: set to Sa'ar Zac Elias
Status: newassigned
Version: 3.4 Beta3.0

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 6129.patch added

comment:2 Changed 7 years ago by Sa'ar Zac Elias

Status: assignedreview

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_failed

The patch looks good, but the positioning of the images are still incorrect, because of the extra white-space they have at the right side (some of them even missing it).

So, before proceeding with this patch, please commit new images directly, being sure all of them have 4px padding at right and left.

Changed 7 years ago by Sa'ar Zac Elias

Attachment: images.zip added

comment:4 Changed 7 years ago by Sa'ar Zac Elias

Status: review_failedreview

comment:5 Changed 7 years ago by Frederico Caldeira Knabben

The new files are still bad. Not the labels are out of alignment.

I'll come with new files to be used on commit.

Changed 7 years ago by Frederico Caldeira Knabben

Attachment: images_2.zip added

comment:6 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:7 Changed 7 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [5871].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy