Opened 7 years ago

Closed 7 years ago

#6146 closed Bug (fixed)

IE: Floating panels offset when editor is within a container that has defined width

Reported by: Damian Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.4.1
Component: UI : Floating Panel Version: 3.0
Keywords: IBM IE Cc: satya_minnekanti@…

Description

See attached screenshot for example.

Steps to reproduce:

  1. Open sample provided with ticket in IE7.
  2. Ensure that the window size of the browser is small enough to cause a horizontal scrollbar to appear in the window
  3. Open a panel.

Result: the floating panels render off-screen. This is a major globalization problem.

Sample to test with:

<html>
	<head>
		<meta content="text/html; charset=utf-8" http-equiv="content-type" />
		<script type="text/javascript" src="ckeditor_source.js"></script>
		<script type="text/javascript">
			function loadEditor() {
				CKEDITOR.appendTo("content", {language: "he", skin: "kama"});
			}
		</script>
	</head>
	<body onload="loadEditor();" dir="rtl">
		<div style="width: 800px; border: 1px dashed black;">
			<div id="content">
		</div>
	</body>
</html>

Attachments (5)

IE_FloatingPanelProblem.png (13.2 KB) - added by Damian 7 years ago.
6146.patch (3.2 KB) - added by Sa'ar Zac Elias 7 years ago.
IE_FloatingPanelProblem_2.png (10.6 KB) - added by Damian 7 years ago.
IE_FloatingPanelProblem_3.png (11.6 KB) - added by Damian 7 years ago.
6146_2.patch (1.3 KB) - added by Frederico Caldeira Knabben 7 years ago.

Download all attachments as: .zip

Change History (17)

Changed 7 years ago by Damian

Attachment: IE_FloatingPanelProblem.png added

comment:1 Changed 7 years ago by Sa'ar Zac Elias

Status: newconfirmed

comment:2 Changed 7 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedassigned

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 6146.patch added

comment:3 Changed 7 years ago by Sa'ar Zac Elias

Milestone: CKEditor 3.4.1
Status: assignedreview
Version: 3.0

comment:4 Changed 7 years ago by Damian

This definitely works better now.

When the user scrolls to the left, it still throws the panel alignment off a bit (see attachment IE_FloatingPanelProblem_2.png.

Also, this issue affects the colour picker panels too, see IE_FloatingPanelProblem_3.png.

Changed 7 years ago by Damian

Changed 7 years ago by Damian

comment:5 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_failed

comment:6 Changed 7 years ago by Sa'ar Zac Elias

Keywords: IE added

Weird, but I'm not able to reproduce it anymore with IE8 in all modes in both trunk and the 3.4 branch.

comment:7 Changed 7 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:8 Changed 7 years ago by Frederico Caldeira Knabben

Owner: changed from Sa'ar Zac Elias to Frederico Caldeira Knabben
Status: review_failedassigned

I'm able to reproduce the problem with IE8 in all modes.

comment:9 Changed 7 years ago by Frederico Caldeira Knabben

Actually, I've noticed that the TC is on quirks, so I was able to reproduce it on IE8+Quirks and IE8+Compat. It's ok with IE8+Standards.

Changed 7 years ago by Frederico Caldeira Knabben

Attachment: 6146_2.patch added

comment:10 Changed 7 years ago by Frederico Caldeira Knabben

Status: assignedreview

I've noticed that even IE8 mode has issues in this tc, even if in a different way.

The provided patch should be able to fix it in quirks (IE6), IE7 and IE8 modes.

comment:11 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:12 Changed 7 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with [5826].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy