Opened 7 years ago

Closed 7 years ago

#6150 closed Bug (fixed)

Select color dialog is broken in Safari 3

Reported by: Wiktor Walc Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.4.3
Component: General Version: 3.3
Keywords: Cc:

Description

Since CKEditor 3.3 the "Select color" dialog is broken in Safari 3. To reproduce press "Background color" -> "More colors".

Confirmed on Safari 3.2.3 @ XP, it might be worth to check what caused it because I do not see this error in CKEditor 3.2.2.

Attachments (2)

select_color_safari3.jpg (52.6 KB) - added by Wiktor Walc 7 years ago.
6150.patch (1.4 KB) - added by Sa'ar Zac Elias 7 years ago.

Download all attachments as: .zip

Change History (13)

Changed 7 years ago by Wiktor Walc

Attachment: select_color_safari3.jpg added

comment:1 Changed 7 years ago by Wiktor Walc

Status: newconfirmed

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Works well with Safari 4.

comment:3 Changed 7 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: confirmedassigned

comment:4 Changed 7 years ago by Tobiasz Cudnik

Milestone: CKEditor 3.4.1CKEditor 3.5

This error is due to too much markup inside a color table. It may be partially caused by complicated dialog markup itself.

Removing some parts of all rows (like styles, aria and events) makes color table visible. Reducing number of rows inside of table also results in visible table.

I'm proposing postponing it to 3.5 and rewriting it to styled UL list.

comment:5 Changed 7 years ago by Frederico Caldeira Knabben

Based on the screenshot, it looks like a broken innerHTML assignment. Maybe the fix is not so hard, and we may not need such a drastic change.

Let's have some further investigation before proceeding with it.

comment:6 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.5CKeditor 3.4.3

comment:7 Changed 7 years ago by Garry Yao

Owner: Tobiasz Cudnik deleted
Status: assignednew

comment:8 Changed 7 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: newassigned

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 6150.patch added

comment:9 Changed 7 years ago by Sa'ar Zac Elias

Status: assignedreview

The event call breaks the innerHTML assignment.

comment:10 Changed 7 years ago by Tobiasz Cudnik

Status: reviewreview_passed

Very interesting solution.

comment:11 Changed 7 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [6141].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy