Opened 9 years ago

Closed 9 years ago

#6156 closed Bug (worksforme)

Order of Style Elements is Wrong

Reported by: Michael G. Schneider Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: 3.4 Beta
Keywords: Cc:

Description

With CKEditor v3.4b, Windows 7, IE 8 or FF3.6 or Chrome 5. Suppose you have the following styleset

{ name : 'normal', element : 'p' }, { name : 'red', element : 'p' , attributes: { "class": "red" }}, { name : 'green', element : 'p' , attributes: { "class": "green" }}, { name : 'blue', element : 'p' , attributes: { "class": "blue" }}, { name : 'h1', element : 'h1' }, { name : 'h2', element : 'h2' }

If you then look at the combobox list, you will see the order: red, blue, h2, h1, green, normal. I expect the order to be as definied in the array.

Michael

Attachments (1)

krst_16.16.13.png (3.4 KB) - added by Krzysztof Studnik 9 years ago.
Order of styles is as in config. Cannot reproduce in CKE v3.4.1 trunk

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by Krzysztof Studnik

Attachment: krst_16.16.13.png added

Order of styles is as in config. Cannot reproduce in CKE v3.4.1 trunk

comment:1 Changed 9 years ago by Krzysztof Studnik

Component: GeneralCore : Styles
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy