Opened 9 years ago

Closed 7 years ago

#6186 closed Bug (wontfix)

FCK Editor: FireFox remove tags

Reported by: alexandrigo Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Here my content:

<div>
  <strong>
    Text
  </strong>
  <span style="font-size: 14px;">
    <strong>
      <br/>Text1
    </strong>
    <div>
      Set cursor at start of this line and press backspace.
    </div>
  </span>
</div>

Set cursor before "Set" word and just press to backsoace(remove previos symbol). And some magic is happens. Reproduced only in FireFox

Change History (3)

comment:1 Changed 9 years ago by Tobiasz Cudnik

Status: newpending

We need more informations:

  • What is the output you're getting ?
  • What's the expected output ?
  • What enterMode is set in your config ?

comment:2 Changed 9 years ago by alexandrigo

FCKConfig.EnterMode = 'br' ;
FCKConfig.ShiftEnterMode = 'div' ;


  1. paste source and set cursor to line start:

http://img686.imageshack.us/img686/8278/selection008m.png[[BR]]

  1. remove one symbol before by press backspace key



Result:
http://img826.imageshack.us/img826/6743/selection009b.png - Text moved up and loosed style.

expected:
http://img820.imageshack.us/img820/4448/selection011.png - Just remove previous symbol and cursor move to line up
Just try it. It's real )

comment:3 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: pendingclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy