Opened 9 years ago

Closed 7 years ago

#6204 closed Bug (worksforme)

IE: Spurious html tags wrap links on paste

Reported by: Jude Allred Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Not reproducable in Firefox or Chrome.

I've also seen '<span style="..."> ... </span>' wrap the links, but I don't have a solid repro for that.

This bug is dependant on the stylesheet which is being run with ckeditor. The stylesheet that ckeditor.com/demo is using doesn't exhibit this bug, so step 4 is entirely about augmenting the demo's css to show the bug. In my production environment, custom templates are allowed on the wiki: One such template gives special coloring and text-decoration to 'a', and that revealed this bug.

Here's the repro for the <u> tags:

  1. use IE8
  1. go to ckeditor.com/demo
  1. set the editor source to:
<p>
	some say <a class="wikiNew" href="default.asp?W2648">i am a link</a></p>
  1. switch back to wysiwyg mode
  1. use the IE8 dev tools to inspect the 'i am a link' href click the 'style' tab click the link to 'contents.css' so we can edit the styles replace the "TEXTAREA" style with the following rule:
       A
         text-decoration: none;
    
  1. Look at the editor-- you'll see that 'i am a link' is no longer underlined.
  1. in the editor, select "some say i am a link"
  1. copy and paste this text using ctrl+c, ctrl+v
  1. Notice that 'i am a link' is again underlined
  1. inspect the source; here's what I got:
    <p>
    	some say <a class="wikiNew" href="default.asp?W2648">i am a link</a></p>
    <p>
    	some say <a class="wikiNew" href="default.asp?W2648"><u>i am a link</u></a></p>
    
  1. [BUG] notice that there's an extra <u></u> wrapped around 'i am a link'. [Expected] The copy paste didn't inject anything new.

Attachments (1)

krst_11.23.32.png (74.3 KB) - added by Krzysztof Studnik 9 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 9 years ago by Jude Allred

"... so step 4 is entirely ..." should read 'step 5'. I altered the numbering after writing that.

Changed 9 years ago by Krzysztof Studnik

Attachment: krst_11.23.32.png added

comment:2 Changed 9 years ago by Krzysztof Studnik

Status: newpending

I attached screenshot with result from steps 1 - 6. The missing underline is not reproducing in my IE8.
Also Copy/Paste, works as expected :

<p>
	some say <a class="wikiNew" href="default.asp?W2648">i am a link</a></p>
<p>
	some say <a class="wikiNew" href="default.asp?W2648">i am a link</a></p>

Is there something that I am missing?

comment:3 Changed 9 years ago by Jude Allred

Perhaps you're need to refresh the page within the IE dev tools?

Here's a video of the repro: underlining.avi I've hosted it on a dedicated ftp server for you:

ftp://ftp1931155:YQZaPubs@ftpny.fogcreek.com

comment:4 Changed 9 years ago by Jude Allred

[edits:] s/you're/you'll newline intended after 'underlining.avi' (I didn't press enter twice...)

comment:5 Changed 7 years ago by Jakub Ś

Resolution: worksforme
Status: pendingclosed

Checked under latest CKEditor 3.6.2 and issue is not reproducible.

Closing the ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy