Opened 5 years ago

Closed 14 months ago

#6229 closed Bug (duplicate)

Underline is not colored when applied to colored text

Reported by: imprev Owned by:
Priority: Normal Milestone:
Component: General Version: 3.2.1
Keywords: Cc: satya_minnekanti@…

Description

  1. Color a piece of text
  2. Underline the piece of text

Notice that while the text is colored, the underline is not.

NOTE: If you underline first (or re-color the text after it is underlined) the underline is colored.

Attachments (1)

Picture+43.png (12.2 KB) - added by imprev 5 years ago.
See attachement

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by imprev

See attachement

comment:1 follow-up: Changed 5 years ago by imprev

Our developer's comments: The "color" style-rule is applied to a <span> that wraps the text node. Selecting your text in the edited AFTER coloring and then clicking the underline button wraps the <span> tag in a <u> tag. The <u> tag, because of the fact that it sits outside the <span> tag, is not affected by our color rule.

Sample code:

<u><span style="color: red;">I am red, but my underline is black!</span></u>

comment:2 Changed 5 years ago by satya

  • Cc satya_minnekanti@… added

comment:3 in reply to: ↑ 1 Changed 5 years ago by krst

  • Status changed from new to confirmed

Replying to imprev:

Sample code:

<u><span style="color: red;">I am red, but my underline is black!</span></u>

Confirmed on CKE 3.4.1 nightly

comment:4 Changed 5 years ago by fredck

  • Keywords color underline removed

comment:5 Changed 14 months ago by m.lewandowski

  • Resolution set to duplicate
  • Status changed from confirmed to closed

Duplicate of #1646.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy