Opened 7 years ago

Closed 7 years ago

#6240 closed Bug (fixed)

Font Names & Font Sizes should be shown Left Align even for RTL Languages

Reported by: Satya Minnekanti Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.4.1
Component: General Version:
Keywords: IBM Cc: Damian, joek

Description

To reproduce the defect:

  1. Open User Interface Language Sample.
  1. Type some Text,apply Times New Roman Font and Font Size of 24 to the text.
  1. Change the Language in the drop down to one of RTL(Arabic or Hebrew) Languages.
  1. Keep the cursor in the text and see how the options are displayed in Font Name & Font Size drop downs.

Expected Result:

Options in Font Name & Font Size drop downs should be shown as left aligned even for RTL Languages since we are displaying them in English only. if we display them as Right Align the option is not shown properly for users.

I have attached a screen shot of the Error.

Actual Result:

Options in Font Name & Font Size drop downs are shown as right aligned.

Attachments (3)

Options display in English.jpg (49.2 KB) - added by Satya Minnekanti 7 years ago.
Options display in RTL Language.jpg (61.8 KB) - added by Satya Minnekanti 7 years ago.
6240.patch (1.2 KB) - added by Tobiasz Cudnik 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by Satya Minnekanti

Changed 7 years ago by Satya Minnekanti

comment:1 Changed 7 years ago by Tobiasz Cudnik

Milestone: CKEditor 3.4.1
Owner: set to Tobiasz Cudnik
Status: newassigned

Changed 7 years ago by Tobiasz Cudnik

Attachment: 6240.patch added

comment:2 Changed 7 years ago by Tobiasz Cudnik

Status: assignedreview

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

Well done. It's a matter of reading direction, not alignment.

The nice part of it is that one can override the styles, if the combo entries get translated.

comment:4 Changed 7 years ago by Tobiasz Cudnik

Resolution: fixed
Status: review_passedclosed

Fixed with [5868].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy