Opened 9 years ago

Closed 8 years ago

#6259 closed Bug (wontfix)

Redirection URL is incorrect when clicking inserted image in CKEditor

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IBM Cc: Damian, joek

Description

To reproduce the defect:

  1. Open Ajax sample & Click on Image icon.
  1. On Image Properties dialog, enter URL(http://www.baidu.com/img/baidu_logo.gif) in URL field on Image Info Tab.
  1. Click on Link Tab and enter URL(http://www.baidu.com) in URL field on Link Tab.
  1. Click OK button to insert the image.
  1. Click on Remove Editor button and Click on Image in the page.

Expected Result:

www.baidu.com web page is opened.

Actual Result:

An Error page is opened.

Change History (4)

comment:1 Changed 9 years ago by Sa'ar Zac Elias

Status: newpending

I'm not able to reproduce the issue using IE8 and FF 3.6.

comment:2 in reply to:  1 Changed 9 years ago by Satya Minnekanti

Replying to Saare:

I'm not able to reproduce the issue using IE8 and FF 3.6.

To reproduce the defect remove http:// from the URL in step 3.

comment:3 Changed 8 years ago by Satya Minnekanti

I could still reproduce this defect..just remove the protocol http:// from the URL in step 3... Please re open this defect

comment:4 Changed 8 years ago by Sa'ar Zac Elias

Cc: damo,joekdamo, joek
Resolution: wontfix
Status: pendingclosed

Actually this field should contain a full URL, so one could be sent to a relative page as well.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy