Opened 7 years ago

Closed 6 years ago

#6263 closed Bug (fixed)

Safari : Cell Properties option is disabled in Pasted Table Cells when we invoke context menu by keeping cursor inside text

Reported by: Satya Minnekanti Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.6.1
Component: General Version: 3.4.1
Keywords: IBM Safari Cc: Damian, joek

Description

To reproduce the defect:

  1. In Safari Open Ajax sample.
  1. Copy a Table with content from MS Word and paste it in to editor.
  1. Keep the cursor inside text in Table Cells, Activate context menu and go to Cell sub menu.

Error:

Cell Properties option is disabled. but when we keep cursor out side the text or in an Empty cell & Activate Context menu Cell properties option is enabled.

Expected Result:

Cell Properties option should be enabled all the time irrespective of the cursor position inside Table Cell.

Attachments (3)

krst_15.02.29.png (68.0 KB) - added by Krzysztof Studnik 7 years ago.
Confirmed on 3.4.1 nightly
simple table.doc (23.5 KB) - added by Satya Minnekanti 6 years ago.
6263.patch (776 bytes) - added by Sa'ar Zac Elias 6 years ago.

Download all attachments as: .zip

Change History (15)

Changed 7 years ago by Krzysztof Studnik

Attachment: krst_15.02.29.png added

Confirmed on 3.4.1 nightly

comment:1 Changed 7 years ago by Satya Minnekanti

we can't even Delete Rows,Columns & Cells when we keep the cursor inside the text. Even though the option is shown as enabled when we click on that option nothing happens.

comment:2 Changed 7 years ago by Satya Minnekanti

we can't even Split Cells Horizontally or Vertically when we keep the cursor inside the text in Table Cells. Even though the option is shown as enabled when we click on that option nothing happens.

comment:3 in reply to:  1 Changed 7 years ago by Krzysztof Studnik

Keywords: Safari added
Status: newconfirmed
Version: 3.4.1 (SVN - trunk)

Replying to satya:

we can't even Delete Rows,Columns & Cells when we keep the cursor inside the text. Even though the option is shown as enabled when we click on that option nothing happens.

Confirmed for table pasted from Word. In table created in CKE, ewerything works fine

we can't even Split Cells Horizontally or Vertically when we keep the cursor inside the text in Table Cells. Even though the option is shown as enabled when we click on that option nothing happens.

Confirmed, as above.

  • Confirmed for pasting table via keyboard Ctrl+V and Context menu - Paste
  • I was able to split and delete cells in table created in CKE, with cursor inside text.
  • In Chrome7 ewerything works fine, so it seems it is safari bug

comment:4 Changed 7 years ago by Martin

Owner: set to Martin
Status: confirmedassigned

comment:5 Changed 7 years ago by Martin

The problem is that the Safari automatically select text on which was clicked right mouse button.

comment:6 Changed 6 years ago by Garry Yao

Cc: damo,joekdamo, joek
Status: assignedpending

WFM, can you provide a sample page?

comment:7 in reply to:  6 Changed 6 years ago by Satya Minnekanti

Replying to garry.yao:

WFM, can you provide a sample page?

Use any sample and copy the table from attached word doc and paste in to editor. As mentioned in step 3 keep cursor inside the text in table cell.Invoke context menu and see Cell Properties option disabled. I could still reproduce this on nightly build.

Changed 6 years ago by Satya Minnekanti

Attachment: simple table.doc added

comment:8 Changed 6 years ago by Frederico Caldeira Knabben

Status: pendingconfirmed

Confirmed with Safari.

The same issue can be seen with Firefox. Simply select the full text of the cell before opening the context menu. In Safari this is not needed because the selection happens automatically on right-click.

This happens because the cell contents are included in a <p> tag.

Changed 6 years ago by Sa'ar Zac Elias

Attachment: 6263.patch added

comment:9 Changed 6 years ago by Sa'ar Zac Elias

Owner: changed from Martin to Sa'ar Zac Elias
Status: confirmedreview

comment:10 Changed 6 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:11 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.1

comment:12 Changed 6 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [6918].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy