Opened 7 years ago

Closed 7 years ago

#6278 closed Bug (fixed)

comment tags get moved to top

Reported by: MBcode Owned by: Paweł Horzela
Priority: Normal Milestone: CKEditor 3.5.1
Component: Core : Output Data Version: 3.4
Keywords: Cc:

Description (last modified by Krzysztof Studnik)

Hey there, In Source editing mode paste original default Text:

%header%<br />
<br />
<!--start:problem[0]--><br />
<!--stop:problem[0]--><br />
<!--start:result[0]--><br />
<!--stop:result[0]--><br />

<!--start:info[0]--><br />
<!--stop:info[0]--><br />
<!--start:end[0]--><br />
<!--stop:end[0]--><br />
<br />
<!--start:sorry[0]--><br />
<!--stop:sorry[0]--><br />
<br />
%footer%

Switch to WYSIWYG and back to source editing. it gets formatted to:

%header%<br />
<br />
<!--start:problem[0]--><!--stop:problem[0]--><!--start:result[0]--><!--stop:result[0]--><!--start:info[0]--><!--stop:info[0]--><!--start:end[0]--><!--stop:end[0]--><!--start:sorry[0]--><!--stop:sorry[0]--><br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
%footer%

This isnt rly usefull because I like to use Comments to Insert with Javascript at the given position.

Please fix that! Would be really great.

Attachments (1)

6278.patch (427 bytes) - added by Paweł Horzela 7 years ago.
Patch

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by Krzysztof Studnik

Component: GeneralUI : Source View
Description: modified (diff)
Keywords: comment tags removed
Status: newconfirmed

Confirmed on 3.4.1 Nightly & Demo. Source formating is lost in above case. I changed formating of issue.

comment:2 Changed 7 years ago by Paweł Horzela

Owner: set to Paweł Horzela
Status: confirmedassigned

Changed 7 years ago by Paweł Horzela

Attachment: 6278.patch added

Patch

comment:3 Changed 7 years ago by Paweł Horzela

Status: assignedreview

comment:4 Changed 7 years ago by Paweł Horzela

It looks like regression, introduced in 3.1 (revision 5103): http://dev.ckeditor.com/changeset/5103

by fixing the ticket #4886: http://dev.ckeditor.com/ticket/4886 http://rev.ckeditor.com/index.php?pageID=10

comment:5 Changed 7 years ago by MBcode

Is there any ETA for the fix? Seems that the patch not work. I also noticed latest comment, so there wont be a fix? :(

patch -p0 < 6278.patch 
(Stripping trailing CRs from patch.)
patching file _source/core/htmlparser/fragment.js
Hunk #1 FAILED at 386.
1 out of 1 hunk FAILED -- saving rejects to file _source/core/htmlparser/fragment.js.rej

comment:6 Changed 7 years ago by Wiktor Walc

Milestone: CKEditor 3.5.1

comment:7 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:8 Changed 7 years ago by Sa'ar Zac Elias

Component: UI : Source ViewCore : Output Data
Resolution: fixed
Status: review_passedclosed

Fixed with [6284].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy