Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6446 closed Bug (duplicate)

Element style trashing in IE7 due to case change

Reported by: Dinu Owned by: Garry Yao
Priority: Normal Milestone:
Component: Core : Output Data Version: 3.4.1
Keywords: IE Cc:

Description

In IE7, the styles are on a upper-lower-case carousel...

To reproduce (IE7):

  • Insert smiley
  • Image properties -> add style "background:url (UPPERCASE)"
  • Image properties again -> style is changed to "BACKGROUND: url(UPPERCASE)" (not wrong yet, but still inconsistent)
  • Switch to source view; style is now "background:url('''uppercase)" (this is wrong)

If there were a <div> with a set background with uppercase characters, it would be trashed as a result of:

  • the operations above
  • directly when replacing <textarea>

Attachments (1)

6446.patch (1.2 KB) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 7 years ago by Dinu

Found to be also present in IE8, seemed it worked but it doesnt.
New test case:

<div id="container"><div style="background:url(someUppercaseUrl)"></div></div>

ckeditor() on container, then destroy(), someUppercaseUrl should preserve case (doesnt happen now)

FF, Opera and Safari seem unaffected

Changed 7 years ago by Garry Yao

Attachment: 6446.patch added

comment:2 Changed 7 years ago by Garry Yao

Component: GeneralCore : Output Data
Keywords: IE added
Milestone: CKEditor 3.5
Owner: set to Garry Yao
Status: newreview

Indeed a serious bug, affects all IE versions though.

comment:3 Changed 7 years ago by Dinu

Looking at the patch, that was not my point:
The problem is that
url(someUppercasedUrl)
gets converted to
url(someuppercasedurl)

The choice of style case is purely cosmetic (url vs URL), although it would be nice to preserve the one users input. However, urls ARE case-insensitive, they should be preserved exactly. After some research, case-sensitive components should be:

  • style:font-family (aliased style:font)
  • style:background-image (aliased style:background)
  • style:list-style-image (aliased style:list-style)

(as per http://www.w3schools.com/css/css_reference.asp)

comment:4 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Resolution: duplicate
Status: reviewclosed

dup of #5930

comment:5 Changed 7 years ago by Sa'ar Zac Elias

Milestone: CKEditor 3.5
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy