Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#6576 closed Bug (invalid)

FCKEditor 2.6.5 & Internet Explorer 9

Reported by: Dave Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.5
Keywords: Cc: dave@…

Description

We have a non-ending list of problems when using IE9 with FCKEditor v2.6.5. Once we solve one problem, the next problem appears. After solving the problem with the toolbar buttons (due to the IE opacity filter which was removed from IE9), we now have following problems which we can not solve :

  1. When placing the cursor on a link and opening the link dialog, the link URL is not displayed. This is because IE9 loses the cursor position in the editor window. Hence no selection is found (the parentElement is the whole document instead of the a element).
  1. When adding an object, the internal code uses the tag fck:object. The colon : gives a problem in IE9.

Could you advise us on the code files and changes we have to add to make this work ?

Thanks in advance. D.

Change History (6)

comment:1 Changed 8 years ago by Alfonso Martínez de Lizarrondo

IE9 is currently a beta, so you should try to file bugs in their site so they are aware of problems in their new rendering engine.

If there are problems in FCKeditor that you know to how to fix, then you should provide here the patches so they can be evaluated in order to check if it's feasible to make FCKeditor compatible with IE9, but in the long term you should plan the upgrade to CKEditor.

At the very least, #6324 will be quite hard to fix if MS doesn't corrects the underlaying problem, so it wouldn't make sense to try to fix other minor issues.

comment:2 Changed 8 years ago by Garry Yao

I'm checking now those reported issues in CKEditor.

  1. When placing the cursor on a link and opening the link dialog, the link URL is not displayed. This is because IE9 loses the cursor position in the editor window. Hence no selection is found (the parentElement is the whole document instead of the a element).

Not reproducible.

  1. When adding an object, the internal code uses the tag fck:object. The colon : gives a problem in IE9.

Affected with #6580.

comment:3 Changed 8 years ago by neighborwebmaster

An easy workaround is to add this to the head section of your HTML:

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8" />

comment:4 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

FCKeditor is no longer supported. Best solution is to upgrade to CKEditor.

If anyone wishes to use IE9 with FCKeditor he/she should use solution presented by @neighborwebmaster in previous comment.

comment:5 Changed 7 years ago by Anum

Can you please specifically define which html file to modify, the fck_link.html or link.html?

comment:6 Changed 7 years ago by mamta

If anyone wishes to use IE9 with FCKeditor he/she should add

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8" />

to the head section of your file. before define meta title and meta description..

its working good in IE9

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy