Opened 7 years ago

Closed 7 years ago

Last modified 2 years ago

#6611 closed Bug (wontfix)

Align to center or right in lists - text is moved, bullet or number stays

Reported by: Krzysztof Studnik Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: 3.4
Keywords: WebKit CantFix Cc:

Description (last modified by Krzysztof Studnik)

  • open ckeditor/_samples/replacebyclass
  • select default text
  • set it as numbered/bullet list
  • press allign center or allign right

Expected result:
Bullet and text is alligned in the same way (as in MS Word)

Actual result:
number or bullet stays, the text is alligned to center/right

Found under Safari 4/mac, confirmed for Chrome Linux and windows
Under Firefox, opera and IE, works as expected.

Attachments (1)

04.png (24.3 KB) - added by Krzysztof Studnik 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by Krzysztof Studnik

Attachment: 04.png added

comment:1 Changed 7 years ago by Krzysztof Studnik

Description: modified (diff)

comment:2 Changed 7 years ago by Garry Yao

Resolution: wontfix
Status: newclosed

Quite unfortunate this infamous bug of webkit has a quite a long history, we should just wait for fixes at their side.

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: WebKit CantFix added; Webkit removed

comment:4 Changed 2 years ago by Irina

The webkit bug mentioned in comment 2 seems to be fixed but the issue is still reproducible in Chrome and IE. After applying style="list-style-position:inside;" problem can't be reproduced.

comment:5 Changed 2 years ago by Jakub Ś

Thank you for the wrokaround. I don't think however that we can insert lists with that style as default.

Two way solution would be creating such style in styles dropdown and applying it to list in IE or Chrome when alignment is needed.

comment:6 Changed 2 years ago by Piotrek Koszuliński

Weird thing, because the WebKit bug was closed as RESOLVED while I can still reproduce the issue. Nevertheless, we can't help here. I posted a comment under https://bugs.webkit.org/show_bug.cgi?id=15713 to see what's going on.

comment:7 Changed 2 years ago by Anna Tomanek

Summary: Align to center/right in lists - text is moved, bullet/number staysAlign to center or right in lists - text is moved, bullet or number stays
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy