Opened 12 years ago

Closed 7 years ago

#668 closed Bug (wontfix)

[SS] Apply predefined styles to ul/ol

Reported by: anonymous Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: SVN (FCKeditor) - Retired
Keywords: SF Cc: Frederico Caldeira Knabben

Description (last modified by Martin Kou)

Predefine a style class via fckstyles.xml

<Style name="Link list" element="ul">
<Attribute name="class"
value="LinkList" />
</Style>

Then in the editor select text and apply the "Link list" class. What is created is:

<ul class="LinkList">New document</ul>

Which should be

<ul class="LinkList">
<li>New document</li>
</ul>

This could be the case for multiple place where elements are ceated this way. This is the only one I've tested currently. (IE)

The second thing:

  • create a unordered list using toolbar
  • enter text "test item" and place the cursor between

words

  • choose "Link list" from styles

# Nothing happens

  • select "test item" and apply the "Link list" style

# the list is messed up as the result shows

<ul>
<ul class="LinkList">test item</ul>
<li>~ </li>
</ul>

There is no way to apply a predefined style/class to the ul/ol tags.

Best regards

SelfMan


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1249697&group_id=75348&atid=543653R

Change History (8)

comment:1 Changed 12 years ago by Martin Kou

Description: modified (diff)
Reporter: changed from Martin Kou to anonymous

I'm marking this bug to [SS] (Style Selector).


Moved from SF. Original poster: fredck

comment:2 Changed 12 years ago by Martin Kou

Description: modified (diff)

comment:3 Changed 12 years ago by Martin Kou

Description: modified (diff)

comment:4 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Component: GeneralCore : Styles
Version: SVN

With the current SVN I can't get the "LinkList" item to appear in the styles combo unless exactly an existing UL has been selected (in Firefox), or it doesn't never appears (IE, Opera and Safari)

Same behavior exists for LI

comment:6 Changed 11 years ago by Alfonso Martínez de Lizarrondo

#1506 has been marked as dup

comment:7 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added

Hi!

I have a similar results as alfonsoml. I'm marking it as Confirmed.

comment:8 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: confirmedclosed

FCKeditor is no longer supported and I was not able to reproduce this problem in CKE 3.x.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy