Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#6699 closed Bug (invalid)

Html filter lowercases object properties

Reported by: Dinu Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4.2
Keywords: Cc:

Description

Test: in the placeholder plugin, replace _cke_placeholder with _cke_Placeholder. It will break the plugin because in the htmlFiltercallback the P is lowercased.

Change History (4)

comment:1 Changed 8 years ago by Garry Yao

Resolution: invalid
Status: newclosed

"_cke_placeholder" is used as an internal attribute and not intended to be changed.

comment:2 Changed 8 years ago by Dinu

Point is not _cke_placeholder, point is any element having custom attributes will have them lowercased. My external app already in place uses camelback notation custom attributes and it will be a pain to lowercase everything. _cke_placeholder was just to reproduce.

comment:3 Changed 8 years ago by Garry Yao

XHTML prohibit lower-cased attributes, browser lower-case it already before sending to our own html processing.

comment:4 Changed 8 years ago by Dinu

You're right, I missed that spot :) I was relying on the DOM, didn't consider they are serialized/desiarialized before editing.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy