Opened 12 years ago

Closed 12 years ago

#673 closed Bug (worksforme)

File INPUT outside of control breaks submission

Reported by: santac311@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc:

Description

When submitting a webform using IE6 with the FCKEditor 2.2 embedded (via .NET) and one or more INPUT TYPE=file tags that have erroneous values the form cannot submit and throws the following error:

Line: 17 (character 904) Error: Acess Denied File: /editor/js/fckeditorcode_ie_1.js

After debugging, the issue is with the statement: this.originalSubmit();

WORKAROUND:

So far, the only workaround I have found seems to require validation of each INPUT TYPE=file tag to verify that the file path begins with two backslashes ("
" for UNC paths) or that the second character of the path is a ":". While this does help to resolve the issue, it is not a scalable solution for odd file paths and the like.

Please advise as to how this can be resolved to allow file paths to be submitted without requiring this awkward validation.

Thanks!!

-jeff


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1273172&group_id=75348&atid=543653

Change History (2)

comment:1 Changed 12 years ago by Martin Kou

Reporter: changed from Martin Kou to santac311@…

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: newclosed

Works for me... I think this bug is outdated. Please feel free to reopen it if necessary.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy