Opened 9 years ago

Closed 7 years ago

#6905 closed Bug (fixed)

Links are not preserved when a link to an anchor is copied and pasted

Reported by: joolee Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.4
Keywords: Chrome Cc:

Description (last modified by Krzysztof Studnik)

Steps to recreate:

  1. Create an anchor.
  2. Create a link to that anchor.
  3. Go to Source mode and come back to Design mode.
  4. Select the new link to anchor. Copy and paste to another place in the editor.
  5. Double click the link to edit it.

You'll see that the Link Type becomes "URL" not "Link to anchor in the text."

When <a href="#one">link to anchor</a> is copied, <a href="demo#one">link to anchor</a> is pasted.

The reason for step 3 is to get around bug #6641.

Change History (3)

comment:1 Changed 9 years ago by joolee

Forgot to mention that this bug appears in Chrome.

comment:2 Changed 9 years ago by Krzysztof Studnik

Description: modified (diff)
Keywords: Chrome added
Status: newconfirmed
Version: 3.53.4

comment:3 Changed 7 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

I was not able to reproduce it anymore in latest CKEDitor 3.6.4 and Chrome 22

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy