Ticket #6930 (closed Bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Aligning images does not work

Reported by: edvanleeuwen Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: 3.5
Keywords: Drupal Cc:

Description

I am using CKEditor 3.5 with Drupal 6.20 and CKEditor module 6.x-1.2.

When I insert an image and align it to right using the dialog, the preview displays the aligning properly. However, when I save/publish the page, the image is aligned to left. I have noticed in the source that the style definitions have been removed.

If I hack the code and use the align attribute, the aligning does work.

I have attached a screenshot: on top you see the preview/result, on the bottom, you see the CKEditor section.

Attachments

ckeditorissue.gif (77.0 KB) - added by edvanleeuwen 3 years ago.
Screenshot of improperly aligned image

Change History

Changed 3 years ago by edvanleeuwen

Screenshot of improperly aligned image

comment:1 Changed 3 years ago by edvanleeuwen

I think this problem resembles the one described in http://dev.ckeditor.com/ticket/4246.

comment:2 follow-up: ↓ 3 Changed 3 years ago by garry.yao

  • Status changed from new to pending

Would you mind to share browser information as well as the content?

comment:3 in reply to: ↑ 2 Changed 3 years ago by edvanleeuwen

Replying to garry.yao:

Would you mind to share browser information as well as the content?

Browser:

IE 8.0.760.16385 (both compatibility on or off) Chrome 7.0.517.41

Which content would you like?

comment:4 Changed 3 years ago by edvanleeuwen

  • Status changed from pending to closed
  • Resolution set to fixed

The cause of this was that I had 'filtered HTML' as default input format. This strips some CSS tags, particularly the 'style' tag. Solution was to set the input format 'full HTML' as default.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy