Ticket #6947 (closed Bug: fixed)

Opened 3 years ago

Last modified 3 years ago

CKEditor maximize firefox bug

Reported by: Aarron.huls Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc: pub1@…

Description

I am using Firefox 3.6.13. When I hit the "Maximize" button, it does not maximize properly. There is no edit area visible, but if I hit the "Collapse Toolbar" button there is a TINY edit are I can see. I'm talking one line's worth. This is not occurring in IE8, Safari, or Chrome. See pics.

Attachments

Minimized.jpg (317.3 KB) - added by Aarron.huls 3 years ago.
Maximized1.jpg (356.6 KB) - added by Aarron.huls 3 years ago.
Maximized2.jpg (253.4 KB) - added by Aarron.huls 3 years ago.
Minimized.2.jpg (226.8 KB) - added by Aarron.huls 3 years ago.
Minimized.3.jpg (226.8 KB) - added by Aarron.huls 3 years ago.
Maximized1.2.jpg (96.7 KB) - added by Aarron.huls 3 years ago.
Maximized2.2.jpg (94.3 KB) - added by Aarron.huls 3 years ago.
LessonMarks.aspx.html (25.6 KB) - added by Aarron.huls 3 years ago.
LessonMarks.aspx (23.9 KB) - added by Aarron.huls 3 years ago.

Change History

Changed 3 years ago by Aarron.huls

Changed 3 years ago by Aarron.huls

Changed 3 years ago by Aarron.huls

Changed 3 years ago by Aarron.huls

Changed 3 years ago by Aarron.huls

Changed 3 years ago by Aarron.huls

Changed 3 years ago by Aarron.huls

comment:1 Changed 3 years ago by Aarron.huls

My fault on the multiple screen shots. Just look at Minimized.2.jpg, Maximized1.2.jpg, and Maximized2.2.jpg.

comment:2 follow-up: ↓ 3 Changed 3 years ago by garry.yao

  • Status changed from new to pending

Works fine on our sample pages, could rely heavily on your page styling, please upload a sample page for reproducing.

comment:3 in reply to: ↑ 2 Changed 3 years ago by Aarron.huls

I will attach the ASP code for the page that is in the pictures.

Changed 3 years ago by Aarron.huls

Changed 3 years ago by Aarron.huls

comment:4 Changed 3 years ago by abj

  • Keywords fullscreen, full screen, maximize, doctype added
  • Cc pub1@… added

I have the exact same problem. I found out though that the cause is the doctype. If I use _no_ DOCTYPE at all or if I use:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">

...then it won't maximize correctly.

But if I use this one from the sample files:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

...or this one:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

...then it works just fine.

Luckily I don't ruin too much by changing doctype for my page, but any change CKEditor could be made to work even with those doctypes?

PS. I'm using Firefox 3.5.16.

comment:5 Changed 3 years ago by j.swiderski

  • Status changed from pending to closed
  • Keywords fullscreen, full screen, maximize, doctype removed
  • Resolution set to fixed

This issue was fixed in CKEditor 3.5.3.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy