Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#6962 closed Bug (fixed)

Opera: problems with "small hard sign" in russian: ъ

Reported by: Alexander Ilyin Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.6.1
Component: General Version: 3.5
Keywords: Cc: Frederico Caldeira Knabben, garryyao, Hallvord R. M. Steen (Opera Software)

Description

Decription in Russian and suggested solution for v.2 is here: http://lusever.livejournal.com/50932.html and it's not working for 3.5

Problem is when user press "ъ" key, it's interpreted as CTRL+B (bold) combination so user could not input "ъ" in editor.

Attachments (1)

6962.patch (776 bytes) - added by Frederico Caldeira Knabben 6 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 6 years ago by Hallvord R. M. Steen (Opera Software)

Cc: Frederico Caldeira Knabben garryyao added
Status: newconfirmed

Is this a general, known problem? I would expect it to happen in all browsers, not just Opera, though I have not investigated.

This code is not guaranteed to work when users use keyboard layouts (such as Russian) that are typed directly (not through IME) and create keypress events for characters with Unicode value > 1000 (since 1000 is the lowest meta character constant used by CKEditor):

	getKeystroke : function()
	{
		var keystroke = this.getKey();

		if ( this.$.ctrlKey || this.$.metaKey )
			keystroke += CKEDITOR.CTRL;

		if ( this.$.shiftKey )
			keystroke += CKEDITOR.SHIFT;

		if ( this.$.altKey )
			keystroke += CKEDITOR.ALT;

		return keystroke;
	},

comment:2 Changed 6 years ago by Hallvord R. M. Steen (Opera Software)

Cc: Hallvord R. M. Steen (Opera Software) added

comment:3 Changed 6 years ago by Frederico Caldeira Knabben

@hallvord, good observation. Do you think that fixing the constants to values over 10FFFF (the Unicode range top) would be enough at this point?

comment:4 Changed 6 years ago by Hallvord R. M. Steen (Opera Software)

Certainly :). I don't expect any practical uptake of characters outside the current Unicode charts anytime soon..

Changed 6 years ago by Frederico Caldeira Knabben

Attachment: 6962.patch added

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

Keywords: russian ъ removed
Owner: set to Frederico Caldeira Knabben
Status: confirmedreview

Ok, so the fix should be that simple.

comment:6 Changed 6 years ago by Garry Yao

Status: reviewreview_passed

comment:7 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with [6916].

comment:8 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.1

comment:9 Changed 6 years ago by Frederico Caldeira Knabben

Packager file updated with [6817].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy