Opened 12 years ago

Closed 12 years ago

#697 closed Bug (fixed)

Font size transposes lines

Reported by: sirfragalot@… Owned by:
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: General Version:
Keywords: SF Cc: Frederico Caldeira Knabben

Description

Hi,

I've discovered this happens in other HTML editors so I suspect the problem is in the underlying designMode code rather than FCKEditor but perhaps a workaround can be devised.

It happens in Firefox, IE and Netscape so doesn't seem to be browser-specific.

Under certain circumstances, if you select all the text and resize the font (problem doesn't seem to occur with any other operation), some of the lines of the text get transposed.

Assuming the text AAA occurs in the text, this will only occur if: 1/ AAA is italicized such that the enclosing '</span>' tag has no space before it, 2/ AAA occurs on the end of a line (as determined by window size not manually inserting a line break or new paragraph, 3/ Some further words (call them BBB) follow that '</span>' and a normal space (not &nbsp;) and 4/ BBB is followed by CCC in a new paragraph.

Under these conditions, selecting all text and resizing the font, BBB will be transposed to immediately follow CCC and BBB will not be resized although AAA and CCC will be.

For example, the following text: "mainstream cinema. In FPS games, the majority of sounds (the deconstruction in a later chapter of sound files in Urban Terror demonstrates this more fully) are concerned with either defining the environment or sonifying the interface between player and

In cinema, the audience or spectator (both passive descriptors) have no control over the visualization or de-acousmatization of sound."

If you place that in the editor, ensure that 'Urban Terror' is justified to the end of the line (try to add more words before etc.), select 'Urban Terror' exactly (not including any space either side), italicize it, select all text and resize the font to e.g. 16, then the words: "demonstrates this more fully) are concerned with either defining the environment or sonifying the interface between player and"

are transposed immediately after the words: "In cinema, the audience or spectator (both passive descriptors) have no control over the visualization or de-acousmatization of sound." and have not been re-sized.

I have discovered that if the '</span>' has a normal space preceding it then, with all the other conditions above, the error does not occur.

The problem occurs with any other use of <span>...</span> not just italics and does not occur if the enclosing </span> has a space preceding it.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1415153&group_id=75348&atid=543653

Change History (2)

comment:1 Changed 12 years ago by Martin Kou

Cc: Frederico Caldeira Knabben added
Reporter: changed from Martin Kou to sirfragalot@…

Thanks for the update Mark.

I was able to reproduce it as you have described, but only with Firefox. IE worked well.

As you have said, the word "sounds" (in italics) must be at the end of the line (the window must be resized for it. Only in that specific situation the problem is reproducible.

This is actually an internal issue with the underlying system of the editor: the browser.

We are not able to solve it now, but I expect we'll be able to do something as soon as the new style selector is developed (version 2.5).

Thanks again.


Moved from SF. Original poster: fredck

Hi,

No problem.

Stick the attached file in the editor. Ensure that the italicized 'sounds' is at the end of a line, select all then resize the font.

I just tried this in the demo on your website and the bug is still occurring. Before resize ('sounds' is italicized'):

"mainstream cinema. In FPS games, the majority of sounds (the deconstruction in a later chapter of sound files in Urban Terror demonstrates this more fully) are concerned with either defining the environment or sonifying the interface between player and mainstream cinema. In FPS games, the majority of sounds (the deconstruction in a later chapter of sound files in Urban Terror demonstrates this more fully) are concerned with either defining the environment or sonifying the interface between player and

In cinema, the audience or spectator (both passive descriptors) have no control over the visualization or de-acousmatization of sound."

After re-sizing:

"mainstream cinema. In FPS games, the majority of sounds (the deconstruction in a later chapter of sound files in Urban Terror demonstrates this more fully) are concerned with either defining the environment or sonifying the interface between player and mainstream cinema. In FPS games, the majority of sounds

In cinema, the audience or spectator (both passive descriptors) have no control over the visualization or de-acousmatization of sound. (the deconstruction in a later chapter of sound files in Urban Terror demonstrates this more fully) are concerned with either defining the environment or sonifying the interface between player and"

(and incorrect font sizes as well). Notice that it's split after 'sound's and dumped the rest of that paragraph at the end.

This happens in other editors too so is not a problem with fckeditor but is likely to be the underlying browser code (I did the above test in Firefox but it's the same with other browsers too). It is possible to code around this as I did with the editor I have in wikindx -- from hazy memory the fix is to ensure that the text to be resized changes all </span>[space] combinations are changed to [space]</span> before the operation.

Mark.


Moved from SF. Original poster: sirfragalot

Hi Mark,

I've tried to reproduce it with your instructions, but it is quite confusing, and I was not able to.

Do you think it is possible to have a sample HTML attached as a Test Case? Something like: "just copy it to the source, switch to WYSIWYG, select all, and resize it".

Thanks in advance.


Moved from SF. Original poster: fredck

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.5
Resolution: fixed
Status: newclosed

I'm not anymore able to reproduce it, probably due to [774].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy