Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#6973 closed Bug (worksforme)

Opera: Paste from Word functionality is not working

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version:
Keywords: IBM Opera Cc: Damian, james, c, structures.hallvord@…

Description

To reproduce the defect:

Copy the content from any of the attached doc's with this ticket and paste in to the editor using Ctrl + V or Paste dialog

Expected Result:

Document text should paste properly.

Actual Result:

Document is not pasted properly for some doc's it's not pasting any content.

if you want i can provide you with some more doc's

Attachments (4)

This is a line of text.doc (27.0 KB) - added by Satya Minnekanti 7 years ago.
TestNegativeHeadingIndent.doc (20.5 KB) - added by Satya Minnekanti 7 years ago.
This is a line of text.2.doc (27.0 KB) - added by Satya Minnekanti 7 years ago.
CKEditor pasting issue.doc (24.0 KB) - added by Satya Minnekanti 7 years ago.

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by Satya Minnekanti

Attachment: This is a line of text.doc added

Changed 7 years ago by Satya Minnekanti

Changed 7 years ago by Satya Minnekanti

Changed 7 years ago by Satya Minnekanti

Attachment: CKEditor pasting issue.doc added

comment:1 Changed 7 years ago by Garry Yao

Cc: james c structures.hallvord@… added; James removed
Keywords: Opera added
Status: newconfirmed

list content from word are stripped by Opera browser, leaving only empty elements, tested with Opera 11/Win7, I don't find major problems though with other structures.

comment:2 Changed 7 years ago by Hallvord R. M. Steen (Opera Software)

I don't have Word, copying from OpenOffice seems to work fine and include the lists. (Since when do we support pasting formatted text? Great to see that we now do!)

comment:3 Changed 7 years ago by Damian

So, this looks like an Opera issue (based on Garry's comment)? Has there been any further progress on the issue?

comment:4 in reply to:  2 Changed 7 years ago by Garry Yao

Replying to hallvord@…:

I don't have Word, copying from OpenOffice seems to work fine and include the lists. (Since when do we support pasting formatted text? Great to see that we now do!)

Can you fire a bug on Opera side for the list pasting from MS-Word?

comment:5 Changed 7 years ago by Satya Minnekanti

This one is fixed in Opera 11.10.Please close this defect.

comment:6 Changed 7 years ago by Hallvord R. M. Steen (Opera Software)

Resolution: worksforme
Status: confirmedclosed

Great. A couple of weeks or so ago I finally borrowed a PC with Word on and did some testing, I was a bit concerned that I failed to repro this. Thanks for confirming that it's been resolved :)

comment:7 Changed 4 years ago by Frederico Caldeira Knabben

Component: GeneralPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy