Opened 10 years ago

Closed 10 years ago

#6992 closed Bug (fixed)

[IE7] Selection error when typing text after table

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.5.1
Component: Core : Selection Version: 3.5.1
Keywords: IE Cc:

Description (last modified by Garry Yao)

The bug is only reproducible in and below IE7:

  1. Use enterMode BR;
  2. Load a table as initial contents:
    <table>
    	<tbody>
    	<tr>
    		<td>
    			text
    		</td>
    	</tr>
    	</tbody>
    </table>
    
  3. Put the cursor after the table and start typing
  • Actual Result: JavaScript error thrown;

Attachments (2)

6992.patch (1.0 KB) - added by Garry Yao 10 years ago.
6992_2.patch (1.4 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by Garry Yao

Status: newconfirmed

Regression of [6337].

Changed 10 years ago by Garry Yao

Attachment: 6992.patch added

comment:2 Changed 10 years ago by Garry Yao

Description: modified (diff)
Owner: set to Garry Yao
Status: confirmedreview

It looks like an IE bug when measuring the selection range, confirm it only happens with newly inserted text nodes after a table element at the end of document.

The patch fix the error when doesn't guarantee the correctness of range measurement in this case, while considering it's quite a edge case, we could work later to check a complete solution.

comment:3 Changed 10 years ago by Wiktor Walc

Milestone: CKEditor 3.5.1
Version: 3.5.1 (SVN - trunk)

Changed 10 years ago by Garry Yao

Attachment: 6992_2.patch added

comment:4 Changed 10 years ago by Garry Yao

range::setEndPoint has a serious bug around table, but it happened that we've been accidentally measuring such range from the parent element before (instead of from siblings), so the fix is to use parent as reference to measure it.

comment:5 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:6 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6343].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy