Opened 8 years ago

Closed 8 years ago

#7012 closed Bug (fixed)

Samples - Languages -fast switching between languages causes Editor to crash

Reported by: Krzysztof Studnik Owned by:
Priority: Low Milestone:
Component: General Version: 3.5.1
Keywords: IE Opera Cc:

Description

TestCase

  • Open User Interface languages sample (IE6/7 or Opera11)
  • set focus on kombo box with list of languages, but list should be colapsed.
  • Switch fast between languages using cursor keys or mouse scroll

Expected result
Editor should switch between Interface languages

Actual result
When switching from LTR to RTL allignment language, Editor crashes.

Under Opera, console has exception as attached below:

JavaScript - http://ckeditor.t/cke351/_samples/ui_languages.html
Event thread: change
Uncaught exception: TypeError: Cannot convert 'n.element' to object
Error thrown at line 140, column 422 in <anonymous function: destroy>(n) in http://ckeditor.t/cke351/ckeditor.js:
    n.element.clearCustomData();
called from line 24, column 3851 in <anonymous function: destroy>(l) in http://ckeditor.t/cke351/ckeditor.js:
    m.theme.destroy(m);
called from line 12, column 6 in createEditor(languageCode) in http://ckeditor.t/cke351/_samples/ui_languages.html:
    editor.destroy();
called from line 1, column 0 in <anonymous function>(event):
    createEditor( this.value );

Bug does not occur under Firefox - user must confirm switching of language by pressing Enter

Change History (3)

comment:1 Changed 8 years ago by Garry Yao

Status: newconfirmed

Regression of [6307], caused by destroying the editor when mode is still not loaded.

comment:2 Changed 8 years ago by Krzysztof Studnik

Looks like patch added to issue #7014 helped with solving this one too.

comment:3 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: confirmedclosed

Fixed by #7014.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy