Opened 9 years ago

Closed 6 years ago

#7024 closed Bug (fixed)

Firefox: incorrect button state

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4
Keywords: Firefox Cc:

Description

In some situations the "Bold" button is not working as expected.

  • Load replacebyclass sample
  • Click in the middle of "sample text", "Bold" buton is highlighted (correct)
  • Click on Source button twice to switch to source and back
  • Click in the middle of "sample text", Bold button is not highlighted (wrong)
  • Click on the strong element in the elements path: "Bold" button is still not active (wrong again)
  • Click on the Bold button: strong element is not removed (again, wrong result

Note: it is enough to click somewhere outside of the strong element in the editing area to fix the problem (e.g. after clicking on "You" and then on "sample text", the button started working).

Regression since 3.4.

Change History (4)

comment:1 Changed 9 years ago by Wiktor Walc

Status: newconfirmed

comment:2 Changed 9 years ago by Wiktor Walc

Keywords: Firefox added

comment:3 Changed 9 years ago by Tobiasz Cudnik

#7059 marked as a DUP.

comment:4 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy