Opened 9 years ago

Closed 9 years ago

#7070 closed Bug (fixed)

Extra line break added to the list item when applying a style

Reported by: Wiktor Walc Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.5.1
Component: General Version: 3.5.1
Keywords: Firefox Cc:

Description (last modified by Wiktor Walc)

Use the following selection:

<ul>
	<li>
		aaa [bbb</li>
	<li>
		ccc] ddd</li>
</ul>

and apply bold, italic, underline, font color etc.

Result:

<ul>
	<li>
		aaa <u><em><strong>[bbb</strong></em></u><br />
		<br />
		<br />
		&nbsp;</li>
	<li>
		<u><em><strong>ccc]</strong></em></u> ddd</li>
</ul>

Caused by [6373].

Attachments (3)

7070.patch (573 bytes) - added by Sa'ar Zac Elias 9 years ago.
7070_2.patch (784 bytes) - added by Sa'ar Zac Elias 9 years ago.
7070_3.patch (1.3 KB) - added by Garry Yao 9 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 9 years ago by Wiktor Walc

Status: newconfirmed

Another TC, enter mode = BR, paste the following in source:

<table border="1" cellpadding="1" cellspacing="1" style="width: 500px;">
	<tbody>
		<tr>
			<td>
				aaa</td>
			<td>
				bbb</td>
		</tr>
		<tr>
			<td>
				ccc</td>
			<td>
				ddd</td>
		</tr>
	</tbody>
</table>

select all, apply styles: bold, italic, underline. Result: extra line breaks are added to elements in the first row.

comment:2 Changed 9 years ago by Wiktor Walc

Keywords: Firefox added
Summary: [enterBr] Extra line break added to the list item when applying a styleExtra line break added to the list item when applying a style

Note: it actually happens in all enter modes.

comment:3 Changed 9 years ago by Wiktor Walc

Description: modified (diff)

Changed 9 years ago by Sa'ar Zac Elias

Attachment: 7070.patch added

comment:4 Changed 9 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedreview

comment:5 Changed 9 years ago by Tobiasz Cudnik

Status: reviewreview_failed

Second TC with a table is still not working.

comment:6 Changed 9 years ago by Wiktor Walc

Second TC works for me. But there is a different problem with this patch (so R- anyway):

  • Clear all contents
  • Insert a table
  • type some text in each cell
  • Select All
  • Apply Bold
  • click belowa a table
  • result: it is impossible to move below the table.

comment:7 Changed 9 years ago by Garry Yao

Owner: changed from Sa'ar Zac Elias to Garry Yao
Status: review_failedassigned

Changed 9 years ago by Sa'ar Zac Elias

Attachment: 7070_2.patch added

comment:8 Changed 9 years ago by Sa'ar Zac Elias

Owner: changed from Garry Yao to Sa'ar Zac Elias
Status: assignedreview

comment:9 Changed 9 years ago by Garry Yao

Status: reviewreview_failed

Load the following content and selection and apply any inline style:

<p>[some <br/> <br/>] text</p>
<p>another</p>

Actual Result: Lose one line-break;

comment:10 Changed 9 years ago by Garry Yao

Owner: changed from Sa'ar Zac Elias to Garry Yao
Status: review_failedassigned

Changed 9 years ago by Garry Yao

Attachment: 7070_3.patch added

comment:11 Changed 9 years ago by Garry Yao

Status: assignedreview

Ticket Test added:
run OR view source.

comment:12 Changed 9 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:13 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6382].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy