Opened 7 years ago

Closed 7 years ago

#7092 closed Bug (fixed)

Nested inline styling

Reported by: Frederico Caldeira Knabben Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.5.3
Component: Core : Styles Version: 3.3.2
Keywords: Cc:

Description (last modified by Frederico Caldeira Knabben)

  1. Load the following in the source view (important to be in source view):
<p>
	<strong>Test</strong></p>
  1. Back to wysiwyg, put the caret at the end of the line with mouse click.
  1. Type anything, like "aaa".
  1. Click the Bold button.

Several strange things happen:

  • The elements path will show a nested <strong>.
  • If you continue typing the text will be bold.
  • Even if the text is bold, the toolbar button is not "on" (blue).

Introduced with the 3.3.2. Works well with the 3.3.1.

Confirmed with FF at least.

Attachments (2)

7092.patch (587 bytes) - added by Sa'ar Zac Elias 7 years ago.
7092_2.patch (1.2 KB) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by Frederico Caldeira Knabben

Description: modified (diff)

I've originally reported it with the following HTML to be loaded:

<p><strong>Test</strong></p>

In this case it works well. So, it's important to have the line break after the opener <p>.

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Hum, it looks like the above TC will still not be reproducible always.

The following looks like more reliable:

  1. Load the editor.
  2. Click the "New Page" button.
  3. Type "Test".
  4. CTRL+A
  5. Click Bold.
  6. Go to Source and back to WYSIWYG.
  7. Click to put the cursor at the end of the text.
  8. Type 'aaa'.
  9. Click Bold.

comment:3 Changed 7 years ago by Sa'ar Zac Elias

Status: newconfirmed

comment:4 Changed 7 years ago by Sa'ar Zac Elias

Regression of [5631].

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 7092.patch added

comment:5 Changed 7 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedreview

Changed 7 years ago by Garry Yao

Attachment: 7092_2.patch added

comment:6 Changed 7 years ago by Garry Yao

Owner: changed from Sa'ar Zac Elias to Garry Yao

Isn't it just safe to remove the the cache, as it's mainly for performance consideration while same thing has already done at CKEDITOR.command::setState.

comment:7 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:8 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6432].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy