Opened 7 years ago

Closed 7 years ago

#7174 closed Bug (fixed)

IE9: Cursor path does not load corectly when editor is switched back from source to wysiwyg

Reported by: Krzysztof Studnik Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.5.2
Component: General Version: 3.5.3
Keywords: IE9 Cc:

Description (last modified by Krzysztof Studnik)

Environment

IE9 Browser mode IE9, document mode IE9 standards CKEditor set to source

TC

  • clear contents
  • insert default table
  • in first row type some text
  • switch to source and back to wysiwyg
  • click on first cell in second column (as on attached screenshot)

Expected

caret position is shown in 'status bar of editor'. Example body blockquote table tbody tr td

Actual

The bottom line in Editor is empty, until next operation is done. User is allowed to make nested blockquotes, which is not possible in other browsers (by repeating two last steps and clicking blockquote button).

<blockquote>
  <blockquote>
    <blockquote>
      <table border="1" cellpadding="1" cellspacing="1" style="width: 500px;">
	<tbody>
	  <tr>
		<td>
...

Attachments (2)

krst_20110214-01.png (33.3 KB) - added by Krzysztof Studnik 7 years ago.
Empty bottom bar
7174.patch (463 bytes) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by Krzysztof Studnik

Attachment: krst_20110214-01.png added

Empty bottom bar

comment:1 Changed 7 years ago by Krzysztof Studnik

Description: modified (diff)

comment:2 Changed 7 years ago by Sa'ar Zac Elias

Status: newconfirmed

Changed 7 years ago by Garry Yao

Attachment: 7174.patch added

comment:3 Changed 7 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

comment:4 Changed 7 years ago by Wiktor Walc

Milestone: CKEditor 3.5.2

comment:5 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_failed

The patch does not resolve the issue for me.

comment:6 Changed 7 years ago by Garry Yao

Status: review_failedreview

Rational behind the fix:

  1. We guard the selection change as ( to filter those equivilent ones):

if ( !currentPath.compare( this._.selectionPreviousPath ) ) { ... }

  1. IE9 doesn't allow to compare live nodes (in current doc) with offline ones (in old doc because of switch mode), throws an error but swalled by a catch.
  2. Invalidate the last path cache before unload the doc make it works.

comment:7 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

Path does work, but it seems like SVN puts the line in the wrong place, which failed the patch from working.

comment:8 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6441].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy