Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#7192 closed Bug (fixed)

IE Elements not shown in path bar when we select pre format option with out focus in editor body

Reported by: Satya Minnekanti Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.6.1
Component: General Version:
Keywords: IBM IE Cc: Damian, Teresa Monahan, James Cunningham

Description

To reproduce the defect:

Open ckeditor, with out focus in editor body select Formatted(pre) option in Paragraph Format drop down list.

Expected Result:

Cursor is in editor body and elements path bar will show body and pre tags.

Actual Result:

Cursor is in editor body and elements path bar is empty.

when we keep focus in editor body and select pre format option cursor shown in editor body elements path bar is not empty but it will not show pre tag in it.

Attachments (1)

7192.patch (439 bytes) - added by Sa'ar Zac Elias 6 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by Garry Yao

Status: newpending

WFM on IE7/8/9 at least.

comment:2 in reply to:  1 Changed 7 years ago by Satya Minnekanti

Replying to garry.yao:

WFM on IE7/8/9 at least.

Hi garry, i have tried again this morning on nightly build and i could reproduce it all the time on IE 6,7 & 8

comment:3 Changed 6 years ago by Sa'ar Zac Elias

Cc: damo,tmonahan,jamescundamo, tmonahan, jamescun
Status: pendingconfirmed

Key to reproduce the problem: the editor must be empty.
In fact, focus does not go into editor when selecting ANY of the format options.

comment:4 Changed 6 years ago by Sa'ar Zac Elias

Keywords: IE added

Changed 6 years ago by Sa'ar Zac Elias

Attachment: 7192.patch added

comment:5 Changed 6 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedreview

comment:6 Changed 6 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:7 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.1

comment:8 Changed 6 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [6957].

comment:9 Changed 6 years ago by Sa'ar Zac Elias

Since it is a ugly hack, and after a more general approach had been introduced (probably [6985]), we can now safely revert this change.
Reverted with [7042].

Last edited 6 years ago by Sa'ar Zac Elias (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy