Opened 8 years ago

Closed 8 years ago

#7196 closed Bug (fixed)

IE9 - js error while inserting <form> on selected page-break

Reported by: Krzysztof Studnik Owned by: Garry Yao
Priority: Normal Milestone:
Component: General Version: 3.5.1
Keywords: IE9 Cc:

Description

Environment

IE9

TC

  • open Editor sample with form plugins
  • without setting focus to edit area, press twice page-break button
  • select the first page-break in WYSIWYG
  • press form button
  • in opened dialog window, enter text in required fields
  • press OK

Expected result

  • Previously selected page break is changed into <form></form>.
  • dialog window dissappears.

Actual result

  • Selected page break is changed into Form
  • dialog window does not dissappear
  • JS error is shown in console:
    SCRIPT5007: Unable to get value of the property 'lock': object is null or undefined 
    ckeditor.js, line 92 character 2232
    
  • after second hit on OK button, dialog dissappears.
  • editor is back to normal.

It is rather unlikely that a normal user will use the word in a similar way. But well, error happened :)

Attachments (1)

7196.patch (514 bytes) - added by Wiktor Walc 8 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by Garry Yao

Status: newpending

I have different buggy behavior instead on the precondition, that in IE9 it's impossible to insert two subsequent <hr > by clicking button twice.

comment:2 in reply to:  1 Changed 8 years ago by Krzysztof Studnik

Replying to garry.yao:

I have different buggy behavior instead on the precondition, that in IE9 it's impossible to insert two subsequent <hr > by clicking button twice.

Recheck for IE9Final / CKEditor rev 6559 - I am able to add two <HR>
I am able to reproduce TC.

comment:3 Changed 8 years ago by Wiktor Walc

Milestone: CKEditor 3.5.3
Priority: LowNormal
Status: pendingconfirmed

It looks like in IE9, in wysiwygarea plugin, line 269:

if ( selIsLocked )
	this.getSelection().lock();

this.getSelection() returns null.

Maybe we could add there some simple check before calling lock()?

Changed 8 years ago by Wiktor Walc

Attachment: 7196.patch added

comment:4 Changed 8 years ago by Garry Yao

Supposed to be fixed by #7193.

comment:5 Changed 8 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedassigned

comment:6 in reply to:  3 Changed 8 years ago by Garry Yao

Replying to wwalc:

It looks like in IE9, in wysiwygarea plugin, line 269:

if ( selIsLocked )
	this.getSelection().lock();

this.getSelection() returns null.

Maybe we could add there some simple check before calling lock()?

The patch is able to eliminate it, while it looks much deeper an issue, after the patch dialog get closed, while cursor is now blinking outside the editor (in the host page) makes it unable to type further.

comment:7 Changed 8 years ago by Wiktor Walc

Milestone: CKEditor 3.5.3

comment:8 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Expired on trunk.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy