Ticket #7237 (closed Bug: fixed)

Opened 3 years ago

Last modified 2 years ago

ForcePasteAsPlainText doesn't seem to work for Mac users.

Reported by: jlea9378 Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3
Keywords: Firefox Mac Cc:

Description

ForcePasteAsPlainText doesn't seem to be working for Mac users. They're able to paste in rich text from MS Word, bringing over invalid HTML source code with it. I'm using drupal module ckeditor 6.x-1.2 with ckeditor 3.5.1 on drupal 6.20. I'm not sure if these people are using the Safari browser or Firefox. I have Pasting as Plain Text enabled on the ckeditor module profile admin page, as well as in the ckeditor.config.js file. Also, in case it matters, I have SCAYT set to start automatically.

This problem doesn't affect Windows users using IE or Firefox.

Attachments

MacDoc.docx (33.9 KB) - added by j.swiderski 3 years ago.

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to invalid

According to http://docs.cksource.com/ckeditor_api/symbols/CKEDITOR.config.html#.forcePasteAsPlainText, forcePasteAsPlainText option does not affect pasting from word.

I must admit that from version 3.3.1 till 3.5.3, when this option was set, even the "paste from word" was affected. That was a bug which was fixed in 3.5.4. Now this configuration option works as described in documentation.

If you want to paste everything as plain text only than please set forcePasteAsPlainText to true in your drupal CKEditor module admin page and remove "PasteFromWord" option from CKEditor toolbar.

comment:2 Changed 3 years ago by jlea9378

  • Version changed from 3.5.1 to 3.5.2

I'm confused. We don't have Paste From Word on our toolbar, and we already have forcePasteAsPlainText set to true, yet Mac users are still able to paste in Rich Text.

Changed 3 years ago by j.swiderski

comment:3 Changed 3 years ago by j.swiderski

  • Status changed from closed to reopened
  • Resolution invalid deleted

comment:4 Changed 3 years ago by j.swiderski

  • Keywords Firefox Mac added
  • Status changed from reopened to confirmed
  • Version changed from 3.5.2 to 3.3

I have managed to reproduce it but it took me quite a while.

  1. In my config.js I have set:
    config.forcePasteAsPlainText = true;
    config.scayt_autoStartup = true;
    
  1. In replacebycode sample I have added to editor1:
    ,{ removePlugins : 'pastefromword'} 
    
  2. I have installed OFFICE for MAC 2011 (on MAC 10.6)
  3. I have created sample word file like the one in attachment (see MacDoc.docx)
  4. Copied the content and pasted into editor.

Results: Using toolbar buttons removed the formatting.

Using CRTL+V on MAC and office 2011 (for MAC) didn't change the formatting. The word contents were unchanged.

This is reproducible form CKEditor 3.3 for Firefox browser (Tested only with 4.01).

comment:5 Changed 2 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to fixed

I was not able to reproduce it anymore with latest CKEditor 3.6.2 and Firefox 10.0.2

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy