Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#7289 closed Bug (fixed)

Can't remove empty paragraph first in document that's followed by a table

Reported by: merixzon Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IBM Cc: magnus@…, satya_minnekanti@…

Description (last modified by Krzysztof Studnik)

It does not appear to be possible to remove an empty paragraph in the beginning of a document, which is followed by a table.

To reproduce:

  1. Switch to source mode and insert the following code:
    <p>&nbsp;</p>
    <table border="1" cellpadding="1" cellspacing="1" style="width: 500px; ">
      <tbody>
       <tr><td>&nbsp;</td></tr>
      </tbody>
    </table>
    <p>&nbsp;</p>
    
  2. Switch back to wysiwyg. Now there's an empty paragraph at the top which can't be removed in the wysiwyg mode, as far as I can tell. Can't get rid of it using delete or backspace.

(this also applies to header tags. If you start the document with "<h1>Hello</h1>" instead, you can remove the text in wysiwyg, but you'll be left with "<h1>&nbsp;</h1>".

Tested with Firefox 3.6.13 and Chrome 9 on Linux, and have heard similar reports from Chrome/Windows users.

Change History (4)

comment:1 Changed 8 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added
Keywords: IBM added

comment:2 Changed 8 years ago by Krzysztof Studnik

Description: modified (diff)
Status: newconfirmed
Version: 3.0

Confirmed since CKE v3.0
Empty paragraph in WYSIWYG mode could be visually selected and removed

  • set caret in empty paragraph
  • select paragraph using SHIFT+right cursor key
  • press Delete on keyboard

As a result, paragraph is "deleted", but after switching into source mode, it is still there.

comment:3 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: confirmedclosed

Expired on trunk.

comment:4 in reply to:  3 Changed 7 years ago by Satya Minnekanti

Replying to garry.yao:

Expired on trunk.

@garry.yao i could still reproduce this issue on all IE(6,7,8&9) & safari. It's not possible to delete the empty paragraph using delete or backspace

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy