Opened 8 years ago

Closed 5 years ago

#7298 closed Bug (fixed)

CKEditor

Reported by: Mark Owned by:
Priority: Normal Milestone:
Component: Core : Parser Version: 3.1
Keywords: Cc:

Description (last modified by Krzysztof Studnik)

Editor randomly duplicates code when switching from source view to WYSYWIG (with a specific page that works in browsers) To reproduce:

  1. Enter Source Mode
  2. Paste attached HTML code into editor
  3. Hit Preview – looks as good as it can without the stylesheets
  4. Exit Source mode
  5. Now it looks bad
  6. Try Preview again and you see that it is not even close to how it looked before CKEditor exited source mode and that some elements (and the page) are duplicated in different spots
  7. Enter Source Mode again and compare with original pasted code – very very different

Attachments (1)

IOLKelownaMainNew.html (14.2 KB) - added by Mark 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by Mark

Attachment: IOLKelownaMainNew.html added

comment:1 Changed 8 years ago by Mark

To reproduce: 1) Enter Source Mode 2) Paste attached HTML code into editor 3) Hit Preview – looks as good as it can without the stylesheets 4) Exit Source mode 5) Now it looks bad 6) Try Preview again and you see that it is not even close to how it looked before CKEditor exited source mode and that some elements (and the page) are duplicated in different spots 7) Enter Source Mode again and compare with original pasted code – very very different

comment:2 Changed 8 years ago by Krzysztof Studnik

Component: GeneralCore : Parser
Description: modified (diff)
Status: newconfirmed
Version: 3.5.3 (SVN - trunk)3.1

Updated description.
Confirmed since v.3.1

comment:3 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

I don't see any problems. Content is preserved in the way it should be. There are of course differences in how it looks, but this is due to styling and different width. Unfortunately, since the TC wasn't limited when confirming ticket, I may not see some issue, so if there's still some, we can reopen the ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy