Opened 10 years ago

Closed 10 years ago

#7324 closed Bug (fixed)

Context menus not displaying correctly in IE6 quirks mode

Reported by: Teresa Monahan Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.6.1
Component: General Version:
Keywords: IBM IE Quirks Cc: Damian, Satya Minnekanti, James Cunningham

Description (last modified by Garry Yao)

  1. Remove the doctype line from ui_languages.html and open it in IE6.
  1. Create a bulleted list and right click it to open the context menu.

Problem: The context menu does not display correctly - it is not wide enough for the text content and therefore extra space appears in the context menu.

This is an issue for many context menus in CKEditor e.g Numbered Lists, Table - cells, columns, rows, flash properties etc

Attachments (3)

context_menus_quirks.gif (8.1 KB) - added by Teresa Monahan 10 years ago.
7324.patch (5.3 KB) - added by Garry Yao 10 years ago.
7324_2.patch (1.1 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by Teresa Monahan

Attachment: context_menus_quirks.gif added

Changed 10 years ago by Garry Yao

Attachment: 7324.patch added

comment:1 Changed 10 years ago by Garry Yao

Description: modified (diff)
Owner: set to Garry Yao
Status: newreview

Patch targeting the following issues:

  1. Panel horizontal overflow;
  2. Wrong menu item height;
  3. dialog center aligned field broken.

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: IE Quirks added; quirks removed
Status: reviewreview_failed

The context menu items height is now much higher after patch.

Can you also describe better point "1" in your comment, to be able to verify it?

Changed 10 years ago by Garry Yao

Attachment: 7324_2.patch added

comment:3 Changed 10 years ago by Garry Yao

Status: review_failedreview

For now I'm unable to reproduce the height issue so it would be enough just just fix the panel size.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

That's ugly... but IE6 is uglier... so it's ok to put them together.

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.1

comment:6 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6941].

Note: See TracTickets for help on using tickets.
© 2003 – 2020 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy