Opened 8 years ago

Closed 8 years ago

#7328 closed Bug (fixed)

element attibutes are not preserved between postback

Reported by: Aron Tsang Owned by:
Priority: Normal Milestone:
Component: Server : ASP.Net Version: 3.5.2
Keywords: Cc:

Description

element attibutes are not preserved between postback

Suggested fix, in CKEditorControl.cs

use HttpUtility.HtmlDecode(string value) instead of trying to implement your own with replace on lines 37 and 43

Attachments (1)

7328.patch (560 bytes) - added by kaga 8 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 8 years ago by Wiktor Walc

Status: newpending

Could you provide more information about the bug you have reported? Is it possible that you're talking about an issue reported here: #7283?

comment:2 Changed 8 years ago by Aron Tsang

Hmm...can't reproduce outside of the code my colleague wrote. When I have more time I will try reproducing the bug.

Changed 8 years ago by kaga

Attachment: 7328.patch added

comment:3 Changed 8 years ago by kaga

I think the problem was related to # 7283, but still we can change the decoding - by HttpUtility.HtmlDecode. Thanks for the advice.

comment:4 Changed 8 years ago by Wiktor Walc

Resolution: fixed
Status: pendingclosed

Change to HttpUtility.HtmlDecode has been committed with [6696].

@arontsang if you find a way to reproduce the original issue, please let us know.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy