Opened 8 years ago

Closed 8 years ago

#7353 closed Bug (wontfix)

error in IE9: ';' expected

Reported by: Pieter Fibbe Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.4
Keywords: Cc:

Description

When i run the fck editor 2.6.4 in IE9 i get a javascript error:

';' expected

It seems that in the generated minified file a d/while loop is the problem. I did a local fix in the minified version, here's a patch for the source:

Index: web/pub/fckeditor-2.6.4/editor/_source/internals/fckxhtml.js =================================================================== --- web/pub/fckeditor-2.6.4/editor/_source/internals/fckxhtml.js (revision 126316) +++ web/pub/fckeditor-2.6.4/editor/_source/internals/fckxhtml.js (working copy) @@ -446,7 +446,7 @@

} while ( htmlNode && htmlNode.nodeType == 3 && htmlNode.nodeValue.Trim().length == 0 )

  • } while ( htmlNode && htmlNode.nodeName.toLowerCase() == 'li' )

+ } while ( htmlNode && htmlNode.nodeName.toLowerCase() == 'li' );

return newTarget ;

},

Change History (2)

comment:1 Changed 8 years ago by Wiktor Walc

Status: newpending

Is it possible that you have found this bug in IE9 RC? I do not have this error in IE9 (stable).

comment:2 Changed 8 years ago by Pieter Fibbe

Resolution: wontfix
Status: pendingclosed

I just ran it in the stable version where the problem is gone. Thanks!

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy