Opened 6 years ago

Closed 3 years ago

#7403 closed Bug (fixed)

FF: Dialogs shrink in width in V2 skin when dragged to the right of the screen

Reported by: James Cunningham Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: 3.5
Keywords: FF IBM Cc: Damian, Teresa Monahan, Satya Minnekanti

Description

Steps to reproduce the defect:

  1. Open the skins sample in Firefox.
  1. Open the Table Properties dialog in the V2 skin.
  1. Drag the dialog to the right of the screen (as far right as possible).

Result: The dialog shrinks in width (see screenshot). This happens for all dialogs when dragged to the right of the screen. It also happens in the office skin.

The problem was introduced in 3.5 in changeset 6118 when the getSize function in the dialog/plugin.js was changed from

getSize : function()
{
	if ( !this._.updateSize )
		return this._.size;
	var element = this._.element.getFirst();
	var size = this._.size = { width : element.$.offsetWidth || 0, height : element.$.offsetHeight || 0};

	// If either the offsetWidth or offsetHeight is 0, the element isn't visible.
	this._.updateSize = !size.width || !size.height;

	return size;
}

to

getSize : function()
{
	var element = this._.element.getFirst();
	return { width : element.$.offsetWidth || 0, height : element.$.offsetHeight || 0};
}

The problem can be resolved by using the old getSize function.

Attachments (2)

Firefox_Reduced_Dialog_Width_Defect.PNG (30.7 KB) - added by James Cunningham 6 years ago.
Firefox_Regular_Dialog_Width.PNG (31.4 KB) - added by James Cunningham 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by James Cunningham

Changed 6 years ago by James Cunningham

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed

Dialogs get reduced in FF (3.6, 4) browsers.

jamescun - I'm not sure if the revision number you have given is correct. I have tested this revision and everything seems to work there. I think that revision number for which problems have started is [6241] but of course I may be wrong.

comment:2 in reply to:  1 Changed 6 years ago by James Cunningham

Replying to j.swiderski:

Dialogs get reduced in FF (3.6, 4) browsers.

jamescun - I'm not sure if the revision number you have given is correct. I have tested this revision and everything seems to work there. I think that revision number for which problems have started is [6241] but of course I may be wrong.

I did not check to see which revision this defect was introduced so you are probably right. I got the changeset 6188 from the changes that were delivered for ticket #5084

comment:3 Changed 3 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

I could not reproduce this any more. Checked moono and kama.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy