Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7457 closed Bug (fixed)

It is (still) possible to set width and height fields to zero

Reported by: Sa'ar Zac Elias Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.5.3
Component: UI : Dialogs Version: 3.5.3
Keywords: Cc: satya_minnekanti@…

Description

  • Use this source code:
    <p>
    	<img alt="" src="http://dev.ckeditor.com/chrome/site/logo-ckeditor-dev.png" /></p>
    
  • Right click on the image, open image properties.
  • Set width field to 0. Hit ENTER and confirm the alert.
  • The width field's content is now selected. Hit BACKSPACE, ENTER.

The dialog closes and the image width and height are set to 0.

Attachments (1)

7457.patch (2.5 KB) - added by Sa'ar Zac Elias 9 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by Wiktor Walc

Status: newconfirmed

Changed 9 years ago by Sa'ar Zac Elias

Attachment: 7457.patch added

comment:2 Changed 9 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedreview

comment:3 Changed 9 years ago by Garry Yao

Component: GeneralUI : Dialogs
Status: reviewreview_passed

This's an issue caused by internal commit logic, the fix works, but the value check is a bit verbose, as zero value is already disallowed.

value !== ''

comment:4 Changed 9 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [6632].

comment:5 Changed 9 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

I could still reproduce this issue on nighlty build in all the browsers( FF,Safari, & IE)

comment:6 Changed 9 years ago by Wiktor Walc

@satya - could you provide the list of steps to reproduce the issue and the exact version of the browser?

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy