Opened 9 years ago

Closed 8 years ago

#7529 closed Bug (fixed)

IE 6&7: Error when editing cell properties in table

Reported by: Jakub Ś Owned by: Garry Yao
Priority: Normal Milestone:
Component: General Version: 3.5.3
Keywords: IBM Cc: satya_minnekanti@…

Description (last modified by Wiktor Walc)

Happens in IE6 & IE7

  • Load rev 6478 sample
  • Press "New Page"
  • Switch to source
  • Paste the following code:
    <p>
    	&nbsp;</p>
    <table border="1" cellpadding="0" cellspacing="0">
    	<tbody>
    		<tr>
    			<td style="width: 197px">
    				<p>
    					Ewrew</p>
    			</td>
    			<td style="width: 197px">
    				<p>
    					435</p>
    			</td>
    			<td style="width: 197px">
    				<p>
    					43543543</p>
    			</td>
    		</tr>
    		<tr>
    			<td style="width: 197px">
    				<p>
    					Werw</p>
    			</td>
    			<td style="width: 197px">
    				<p>
    					435</p>
    			</td>
    			<td style="width: 197px">
    				<p>
    					click here</p>
    			</td>
    		</tr>
    		<tr>
    			<td style="width: 197px">
    				<p>
    					435</p>
    			</td>
    			<td style="width: 197px">
    				<p>
    					435435</p>
    			</td>
    			<td style="width: 197px">
    				<p>
    					ertretretre</p>
    			</td>
    		</tr>
    	</tbody>
    </table>
    
  • Switch to wysiwyg
  • Click with RBM on cell with value "click here" (DON'T CLICK WITH LBM) and choose cell -> cell properties...
  • Result: the error is displayed:

'null' is null or not an object

 function getSelectedCells( selection )
 {
      // Walker will try to split text nodes, which will make the current selection
      // invalid. So save bookmarks before doing anything.
     var bookmarks = selection.createBookmarks(); // <-------

     tabletools/plugin.js, line 14

Attachments (2)

ie6_7529.png (115.3 KB) - added by Wiktor Walc 9 years ago.
7529.patch (1.5 KB) - added by Garry Yao 9 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 9 years ago by Jakub Ś

Status: newconfirmed

Changed 9 years ago by Wiktor Walc

Attachment: ie6_7529.png added

comment:2 Changed 9 years ago by Wiktor Walc

On my computer it happens straight after the dialog loads, without having to press the "Ok" button.

comment:3 Changed 9 years ago by Jakub Ś

Description: modified (diff)

comment:4 Changed 9 years ago by Wiktor Walc

Description: modified (diff)

comment:5 Changed 9 years ago by Jakub Ś

Version: 3.4.13.5.3 (SVN - trunk)

comment:6 Changed 9 years ago by Jakub Ś

This has first occured in revision [6478]

comment:7 Changed 9 years ago by Wiktor Walc

Description: modified (diff)

comment:8 Changed 9 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added
Keywords: IBM added

comment:9 Changed 9 years ago by Sa'ar Zac Elias

I'm unable to reproduce the bug for some reason after trying a few times.

comment:10 Changed 9 years ago by Garry Yao

I'm unable to reproduce with either cached dialog or fresh dialog load, looks like a randomly occurring, can we defer it?

Changed 9 years ago by Garry Yao

Attachment: 7529.patch added

comment:11 Changed 9 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

I've figured the key to reproduce this bug is to have a paragraph inside the table cell, it's a really weird bug of IE6/7.

comment:12 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: reviewclosed

Fixed by [6882] on trunk.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy