Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7562 closed Bug (invalid)

PHP cke_protected in dialog

Reported by: datalink Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5.3
Keywords: Cc:

Description

PHP works in attributes, but when open dialog it shows

{cke_protcted_0} 

Example: make a form with

action="<?php echo $_SERVER['REQUEST_URI']; ?>"

source is right, forms dialog value shows protected.

Change History (4)

comment:1 Changed 10 years ago by Jakub Ś

Status: newpending

Could you describe your issue in more detail? We had difficulties understanding what exactly is the problem here.

comment:2 Changed 10 years ago by datalink

<form action="<?php echo $_SERVER['REQUEST_URI']; ?>"></form>

Copy this in a page. Open forms properties dialog and look at action attribute. Value is

{cke_protected}

comment:3 Changed 10 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

I have just spoken to my colleague. This is by design. When you use php tags as html attributes, these tags are available in source mode only. In dialogs they are displayed as cke_protcted_0

Please refer to http://dev.ckeditor.com/ticket/4475 for more details.

comment:4 Changed 10 years ago by datalink

Ok, but I think it's not really userfriendly. Hope it will be fixed in future versions.

Note: See TracTickets for help on using tickets.
© 2003 – 2020 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy