Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#7581 closed Bug (fixed)

IE Crashes when we try to insert a new list item in the pasted list.

Reported by: Satya Minnekanti Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.6.1
Component: Plugin : Paste from Word Version: 3.5.3
Keywords: IBM IE Cc: monahant@…, jamcunni@…

Description

To reproduce the defect:

  1. Copy the list from any of the attached word doc's and paste it using Paste from Word dialog.
  1. See that the list is pasted properly.
  1. Keep cursor next to one of the list items and press Enter.

Expected Result:

New list items starts at the same level.

Actual Result:

Browser crashes . Tested against IE6,IE7

Attachments (3)

Numbering.docx (14.2 KB) - added by Satya Minnekanti 6 years ago.
stupidList.docx (11.0 KB) - added by Satya Minnekanti 6 years ago.
7581.patch (1.0 KB) - added by Garry Yao 6 years ago.

Download all attachments as: .zip

Change History (15)

Changed 6 years ago by Satya Minnekanti

Attachment: Numbering.docx added

Changed 6 years ago by Satya Minnekanti

Attachment: stupidList.docx added

comment:1 Changed 6 years ago by Teresa Monahan

Cc: monahant@… added

comment:2 Changed 6 years ago by James Cunningham

Cc: jamcunni@… added

comment:3 Changed 6 years ago by Jakub Ś

Status: newpending

Works for me. I could not reproduce it.

Does it happen always with any element or some kind of special condition has to be met?

comment:4 Changed 6 years ago by Jakub Ś

Status: pendingconfirmed

I have managed to confirm it. This has been true for IE6 and IE7 from CKEditor version 3.5.3 revision [6616]

  1. Open ajax sample
  2. Copy "stupidList" with CRTL+A CRTL+C
  3. Paste it using paste from word dailog. (If IE asks you whether to allow... press allow)
  4. Place the cursor behind "n" and press enter, the browser will hang.

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

Version: 3.5.33.5.4 (SVN - trunk)

comment:6 Changed 6 years ago by Wiktor Walc

Milestone: CKEditor 3.5.4

comment:7 Changed 6 years ago by Garry Yao

Component: GeneralCore : Lists
Keywords: IE added

Confirmed on old IEs(6&7), probably because of the depth of nested list has brought too much a burden for the browser, I would be hard to have it in this milestone though and it's not a trunk regression.

comment:8 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.5.4CKEditor 3.6.1
Version: 3.5.4 (SVN - trunk)3.5.3

Ops, I made a mistake with the version. I wanted to change the milestone instead.

Anyway, we need to go out with the 3.5.4 now, so I'm postponing it, to be dealt right after the release.

Changed 6 years ago by Garry Yao

Attachment: 7581.patch added

comment:9 Changed 6 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

comment:10 Changed 6 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:11 Changed 6 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6950].

comment:12 Changed 3 years ago by Frederico Caldeira Knabben

Component: Core : ListsPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy