Opened 7 years ago

Closed 7 years ago

#7623 closed Bug (duplicate)

IE8 - SCAYT long running script error on large amounts of text

Reported by: Michael Camden Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 3.2.2
Keywords: IE8 Cc: mcamden@…, WebSpellChecker.net

Description

When using IE8, SCAYT causes the browser to throw a long running script error ('Press OK to stop script') when there are large amounts of misspelled text. Our test case was around 1500-2000 words, 75% misspelled.

Change History (5)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: scayt removed
Status: newconfirmed
Version: 3.5.33.2.2
  1. Create long document with misspelled words (Mine had 9 pages and contained something like "Kjfjsf klfklj flkf sjf flkj fjds ffs shgf gjhgj gf")
  2. Go to ajax sample and create an editor
  3. enable scayt
  4. paste the contents from word using CRTL+V
  5. wait few seconds:)

Result: The info about long running script is displayed.

This is specific only for IE8 from version 3.3.2

comment:2 Changed 7 years ago by Jakub Ś

Error also occured in IE6 but I had to wait at least 3 minutes before I saw the info dialog.

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Cc: WebSpellChecker.net added

comment:4 Changed 7 years ago by WebSpellChecker.net

This is duplicate of #5830

comment:5 Changed 7 years ago by Frederico Caldeira Knabben

Resolution: duplicate
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy