Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#7657 closed Bug (fixed)

BIDI: The wrong indentation is applied when converting indented RTL paragraphs into lists

Reported by: James Cunningham Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.6.1
Component: Core : BiDi Version: 3.5.3
Keywords: IBM Cc: Damian, Satya Minnekanti, Teresa Monahan

Description

Steps to reproduce the defect:

  1. Open the Ajax sample.
  1. Type 3 paragraphs of text.
  1. Indent the 2nd paragraph once.
  1. Indent the 3rd paragraph twice.
  1. Select all 3 paragraphs & click the RTL button in the toolbar.
  1. Selcet all 3 paragraphs & click the numbers/bullets button in the toolbar.

Expected: A list should be created with the 2nd list item having a margin right of 40px & the 3rd list item having a margin right of 80px.

Actual: A list is created with the 2nd list item having a margin left of 40px & the 3rd list item having a margin left of 80px. The wrong indentation is applied which causes the list to lose all indentation.

Attachments (1)

7657.patch (858 bytes) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by Satya Minnekanti

Version: 3.5.4 (SVN - trunk)3.5.3

This is a regression in 3.5.3. it was working since 3.5.2

comment:2 Changed 7 years ago by Jakub Ś

Status: newconfirmed

What @jamescun has described, has started from revision [6551]

But this feature has stopped working properly form revision [6478]

From 6478 to 6551 when applying numbered/bulleted list to selected text it either had no effect or removed the whole list.

Changed 7 years ago by Garry Yao

Attachment: 7657.patch added

comment:3 Changed 7 years ago by Garry Yao

Keywords: BIDI removed
Owner: set to Garry Yao
Status: confirmedreview

comment:4 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.1
Status: reviewreview_passed

comment:5 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6911].

comment:6 Changed 6 years ago by Frederico Caldeira Knabben

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy